Issue with grovepi analog read/analog write

Hello guys,

as a newbie and rookie in python programming I currently do have a problem with my raspberry Pi 3b combined with the grovePi+ -Starter-Kit.
I’ve tried the analog read/write function with a simple Fade-LED-Python-Programm.
I checked the programm on a RaspberryPi in my school and it fully worked on it but on my new own RaspberryPi, there is no function!
Is there any possibility to check what the problem could be?
Further more, how can check, If my grovepi-board is alright?
Many thanks in advance :wink:

Kind regards


What operating system are you using?
The Grove-pi boards won’t work with Bullseye, you need to use the “legacy” O/S - Buster.

Did you download the Grove libraries?


Dear Jim,
first of all thanks for your reply.
Yes, I did download the Grove libraries and also tried a couple of other functions like the lcd display and digital switching.
Here is a screenshot of the operatingsystem

Jim! I just find out the Hardware must be okay because I operated the LED_Fade example which already is in the project folder.
Question: Is it fundamental importend in which path the grovePi files are installed?

Pardon me, for my maybe weird expressions, I usually come from germany :blush:


That’s excellent!

Yes, paths and locations are absolutely critical.  That’s how the programs know where to find all the little pieces and libraries they need.

If you can show me what happens when you try it and it fails, I might be able to help.

Don’t worry!
One of the top engineers at Modular Robotics is French Canadian, I’m a US citizen currently living in Moscow Russia, one contributor is from the Netherlands, another is from France, and a few are back in the States.

Some work on robots using ROS and advanced AI.  Others - like me - experiment with the GoPiGo robot hardware, test the operating system, and do simpler programming.

People come from everywhere and nobody minds.

I guess we’re all a bit “weird” here, but that’s OK.  :wink:  It’s all a part of the fun!


No it is not important where a file you want to run is “located”,


Hello Jim and cyclicalobsessive,

so I gave the whole thing another shot and everything I did before, was checking the grovepi files of completeness and also test I2C -connection again. To my surprise, the grovepi is now running to my absolutely satisfaction😍
One more many thanks to you guys.
Wishing U a beautiful christmas time and happy coding🎄


Maybe, (as @cyclicalobsessive suggested offline), all it needed was a reboot?

Don’t forget to come back and tell us what you’re doing.