JupiterLab/Notebooks : (Python) Kernel error (fail)

dexteros
jupyterlab

#1

After login into “mypigopi.com” and successfully use the DRIVE module to confirm connection. I used “Code in Bloxter” successfully BUT …

When I press the “Code in Python” button taking me to JupiterLabs beta and try to run a file, I get a failure starting kernel. I launched “Classic Notebooks” (via help pull down menu" but kernel also failed.

I am not sure how to proceed to fix this???


#2

Hi @dennys,

That, I think, might be an issue with Jupyterlab that only happens once - that seems to be fixed by rebooting the Raspberry Pi.

Can you show us a screenshot to get a better idea of it?

Thank you!


#3

I was able to replicate after turning off and on the gopigo unit — I also try with “Classic Notebook” and the same error happen – so I got lazy and decided to move to Raspbian OS and by-pass the nice easy-to-use layer (i.e Jupiter labs) and program the old fashion way … not to mention I am now connected via local network.

So I am ok now … but sorry I did not help debug further what the problem might of been.


#4

Hi @dennys,

I’ve tested this yesterday and DexterOS worked absolutely fine for me on Chrome and Edge, though on the latest version of Firefox I got the same issues as you mentioned - not being able to open a notebook, or start a terminal, or create a file.

So, for some reason, FIrefox has an underlying issue that causes all this trouble with JupyterLab.

Were you using Firefox too? And if so, could you try it out in Chrome or Edge?

Thank you!


#5

On my side I try safari and Chrome on the Mac OS and had the “kernel error”. I may try to go back to Dexter OS and see if I can make it work.


#6

We’d really appreciate if you could take a moment to test it with different browsers. At the moment we’re baffled by this issue which I had on Tuesday too. In my case, it disappeared after the nth reboot, all on its own and I can’t reproduce it since. It’s like a phantom issue, and those are the worst to track. Any extra info you can send us is very very appreciated.

Thanks,
Cleo


#7

Hey Cleo,

OK since I am now loaded Rasbian OS – I will go ahead and load back dexter os sometime this weekend and try again in safari, chrome, and firefox.

I might just go and buy a new SD card to do this so I can have both (Dexter and Raspbian) in hand instead :slight_smile:


#8

Thank you,
your help is very appreciated. This is a very weird bug, and it’s kinda funny (as in weird) that we were both hit by it on the same weekend. It’s like it’s related to the moon or something :slight_smile:

And yes, I know about multiple SD cards. I have a DexterOS, a Jessie-based R4R, and Stretch-based R4R, a simple Jessie card, and a simple Stretch card. Soon I’ll have enough to play blackjack :smiley:

Cleo