Just unboxed GrovePi: connects OK via VNC: can't type Underscore in Terminal


#1

Hi all, my name is Mike and I’m a complete Newbie to Raspberry Pi. Just received and unboxed the GrovePi and followed the directions to get it connected to the network. I can easily get to the ‘welcome’ page (Raspbian for Robots) that offers the choices of VNC or Terminal.

Using the instructions on webpage [https://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/], I managed to get down to the middle of Test The Grove Pi. Item 7 has me trying to check the firmware version. I followed the directions to change the directory then tried to type in the command: sudo python grove_firmware_version_check.py When I type the ‘underscore’ character, nothing happens in the Terminal screen. Alpha characters work fine, the hyphen works fine, just not the Underscore. I tried this using a second computer and have the same problem.

The first computer is an HP desktop with an HP keyboard. The other is a Surface Pro 3 with the Surface Type Cover [keyboard].

To type an Underscore, I’m holding down the Shift key and clicking the Hyphen/Underscore key. The key works properly here_ _ but doesn’t populate the character into the Terminal window.

By the way, I have no programming knowledge and it’s been years since I did anything with MSDOS but some of this looks familiar, such as CD to Change Directory. I did a Search in the Forums for the word “underscore” and didn’t find anything that sounded like this problem.

Does anybody have any ideas? Thanks in advance!

Mike


#2

That is weird, It is most likely a vnc bug. I highly recommend using ssh, it is very reliable. Plus there isn’t very mainy reasona to use vnc. If you must run graphical programs run ssh -x pi@your pi’s ip adress. Also try plugging it in to a monitor, keyboard, and mouse etc. Ssh or just plugging in a monitor should work. Also who vnc are you using?


#3

Hey @puomike, does the underscore just not show up in the terminal, or is it not getting entered? For example if you typed out sudo python grove_firmware_version_check.py do you get a response or does it give you an error? It may look like grovefirmwareversioncheck.py, but does it start the program?


#4

graykevinb, thanks for the reply. I was hoping to follow the instructions that came with the kit from Dexter but I will consider your suggestion if I can’t find an easier way. Also, no spare monitors or keyboards are available right now.

JohnC: I am typing on the keyboard attached to the desktop PC, into a Terminal window (in Firefox). Connectivity is via WiFi and I have typed 192.168.1.14 into the browser to get to the Dexter Ind. Raspbian for Robots splash screen with the 2 choices of VNC or Terminal. After logging in, I get a pi@dex:~ $ prompt. I type sudo python grove_firmware_version_check.py but the Terminal screen shows: sudo python grovefirmwareversioncheck.py

The error shows as:
python: can’t open file ‘grovefirmwareversioncheck.py’: [Errno 2] No such file or directory
pi@dex:~ $

Thanks, Mike
PS: screen dump follows:

dex login: pi
Password:
Last login: Thu Dec 22 00:48:12 UTC 2016 on tty1
Linux dex 4.4.38-v7+ #938 SMP Thu Dec 15 15:22:21 GMT 2016 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
xhost: unable to open display ""
pi@dex:~ sudo python grovefirmwareversioncheck.py python: can't open file 'grovefirmwareversioncheck.py': [Errno 2] No such file or directory pi@dex:~


#5

John!!! I on the raspberry pi did you set up your local preferences… i.e. local keyboard, time zone in the localization area on the pi? that would be where I would start troubleshooting. If that area is not set up it will give wrong characters if not set up for your area.


#6

John… I forgot to mention. Localisation is under the PI symbol on the top of your screen under preferences.


#7

Hi andykere,
Thanks for the suggestion on localization. I have looked under the Raspberry (is this the “Pi” you refer to? It’s in the upper left corner followed by Browser, Files, Monitor), in VNC, in Preferences and not found anything about localization. I did go into Main Menu Editor and added some unchecked items to the list of what populates when you select Preferences. I have gone into each menu item under Preferences and not found anything for localization.

I’m running Version 6.10 of Raspbian, modified by Dexter on the Jessie. Updated 2016.10.05

I can’t figure out how to ask VNC what time it is or what date or where I am.
The only menu item for Localisation is under Preferences Add/Remove Software. In the left column I selected Localsation and nothing populates in the right column.

Thanks, Mike


#8

Hello Mike.
Not sure about what it looks like under VNC but should be the exact same view. If you see the raspberry Pi symbol click on it and it should drop down with choices for Programming, office, internet and so on. There should be a choice called programming under which you should see Raspberry Pi Configuration. Under that choice you should see Localisation. Not sure why they spelled it that way other than a spelling error or regional thing in the UK, anyway there you should find menu’s to change Set Locale, Time zone, Keyboard… which I think is your problem and Set Wifi Country. I believe once you set up the correct keyboard for your area and time zone it should fix your keyboard error.

If that still does not work use the command in a terminal window “sudo raspi-config” will do the same. Good luck and happy coding and learning.

Andy


#9

Correction Mike. Under the rasp pi symbol I meant to say under PREFERNCES choice


#10

Mike, I just reread some of your posts I missed. If your at the vnc terminal and only see the Pi@dex or whatever it is… either type startx which will take you into the Pi Gnome screen or type (sudo raspi-config) omit the () of course. That will also take you where you need to be.


#11

andykere,

Thanks for all your efforts. Following your suggestion, I went into Terminal and typed sudo raspi-config and changed as much as I could to my location in California. When I tried to change the keyboard, I got the error update-rc-d: warning: start and stop actions are no longer supported: falling back to defaults. This repeated on 2 lines. Then it said “Reloading keymap. This may take a short while. Session Closed” After a reboot, I still can’t type an underscore.

Then I tried in VNC again and found the Preferences\RaspberryPi Configuration page. I went to Localisation and clicked on Set Keyboard and absolutely nothing happened. I also clicked on Set Locale and Set Timezone and had good luck making changes on both. So, I conclude that my ability to change keyboards is unavailable for some reason.

Thanks, Mike


#12

Hmmm Strange. I need a few hours before I get home and will check and verify on my end if it still works. Just a suggestion… if you have an extra micro sd card load up a a version of jesse from https://www.raspberrypi.org/downloads/ and see if that still happens. My guess… without checking is the version of dex’s rpi for robots. Maybe this is a good one for John to jump in anytime…:slight_smile:

Raspberry Pi Downloads - Software for the Raspberry Pihttps://www.raspberrypi.org/downloads/


Download free software for the Raspberry Pi, including NOOBS, Raspbian, and third party operating system images. Beginners should start with NOOBS.


#13

andykere,
I’ve got a 2 GB Micro SD card laying around that I can use. If I need more capacity, I’ll have to go shopping tomorrow. Company is arriving tonight (in 2 hours) so will get pretty tied up with that for the evening. I wish I had a separate keyboard to hookup directly to the Raspberry Pi but I don’t-maybe if it SAW a keyboard it would let me change it. I’m doing everything via WiFi from my desktop computer as it is. I’ll do that download as soon as I get a chance, thanks for the links.

Question: Do ALL of the brains of the Raspberry Pi reside on the SD card? Is there also a BIOS like on a Windows computer?

Thanks again!
Mike


#14

Mike I am home and I can verify you are correct. I used a new copy of Dex for robots and I also can not get into parts of localisation (Spelling). I did manage through “sudo raspi-config” and it also gave me a hard time but after trying over and over I managed to change the keyboard. Going back to the gui version I tried localization again with a fresh copy of dex and after Dexter_Software_update it wouldn’t let me change keyboard. after clicking and right clicking on it a number of times and pausing I noticed in the upper right the cpu usage was 100% so I waited and it finally opened and let me change the region to the US. I also am from the US… Midwest. I have to tell you this is a pain and needs to be addressed in a future update of Dex for robots. Can’t believe no one else has caught this. Good catch Mike but am sure that’s not what you wanted to hear. Anyway. It can be changed but it’s hit or miss on the clicking on it. It did work for me but rebooting and trying again but after trying again if did not let me change it. Mike… you just have to try slowly since you are using vnc as there is a slight pause between your pc and raspi.

Andy


#15

P.S. I don’t thing two gig chip will work as 4 gig is minimum for regular raspi and guessing Dex’s version needs 8 gig minimum. There’s a lot of good stuff on there…

Andy


#16

Andy,
Well, thanks for verifying that it’s not just a Newbie mistake on my part. I am disappointed that I couldn’t even get past the Getting Started part of this without a hiccup.

I did a little looking on the raspberrypi.org page and agree that my 2GB card is insufficient. I’ll have a couple more memory cards delivered here on the 24th (isn’t Amazon great?) and continue from there.

Have a Merry Christmas Andy!
Mike


#17

Back at cha. MERRY CHRISTMAS & A HAPPY NEW YEAR.


#18

Merry Christmas and Happy New year to you too!

This underscore thing is weird… I never had to set the keyboard on the Pi before. (well not true, I have done it, I just don’t do it anymore). But never did I have an issue with the underscore. This is really puzzling.

@puomike your Windows machine, is it set to another language than either UK English or American English by any chance?


#19

Hi cleoqc!

No, the keyboard is set to US English. I’m in California. I had to hunt around to find it but, while there, I looked to see if there were any other US English keyboard choices that might be worth a try. I couldn’t find anything that looked worth trying. And, don’t forget, my Underscore key (--) works fine in Microsoft Word, Notepad, Firefox, etc. It’s just that when I type an underscore while in VNC or Terminal, nothing happens and the cursor does not move ahead (such as with a Space Bar).

I tend to agree with Andy (that it’s a bug) and I’m kind of hoping that JohnC will jump back in (maybe after the Holidays) with a solution. I am assuming that he works for/at Dexter. Maybe they’d send me another card loaded with the Dexter software (after testing it in-house).

So, in the meantime, I ordered an 8gb card from Amazon with NOOBS on it, plugged it into the Pi, hooked the Pi up to the router and power, and used Fing to find it on the network. I found it and tried to log onto the Pi with it’s address (192.168.1.13) and also with dex.local. Maybe the dex.local is a waste of time since it’s not Dexter’s NOOBS card? No luck logging onto the Pi.

As I said, I’m a complete newbie. While all this has been going on, I received the book I ordered (Raspberry Pi User Guide by Upton and Halfacree). So I’m reading it as I get the chance. The book seems to assume that you will have a separate keyboard, mouse and monitor hooked up to the Pi. This is not my case as I was hoping to access the Pi via the WiFi network (which I was able to do with the Dexter 8gb card). I really don’t care to own more monitors or keyboards, I’m trying to ‘downsize’, not ‘collect’.

Cheers, Mike


#20

thanks for the extra details. Really really weird (but of course once we figure out what the issue is we will all go 'doh, but of course". In the meantime I’m stumped.
I asked about your keyboard setup even though it works on Windows because it might just be sending a different key code, which VNC wouldn’t know how to interpret. But yeah, US English should work.

As for NOOBS, it will install Raspbian but not Raspbian for Robots. The difference between the two is that Raspbian for Robots comes loaded with settings that allow you to NOT have a dedicated keyboard/screen for the Pi. The NOOBS/Raspbian does not allow for dex.local or logging through the browser. On top of that, a recent security update makes it even harder to start a SSH session without a full configuration.

That said, I have many Raspbian for Robots around me, and I use three different types of keyboard (US, UK and French Canadian, even Spanish once in a while). Never had an issue with the underscore. Mind doing a little test for me? Mostly for my curiosity.

Log into dex.local (with Raspbian for Robots).
Start a terminal
Type the following:
hold down the left ALT key (not the right one, just the left)
make sure the numerical keypad is on and type in the following numbers - keep the alt key down : 095 Don’t use the top number keys, it has to be the numbers on the numeric keypad
release the alt key.
What I see in the terminal window:
each number gets shown (095) and upon releasing the alt key, I see the _

This is not going to provide a workaround unfortunately, but is should help in seeing where the issue is. If you’re not seeing the _ then the problem is with the Pi. If you are seeing it, then the problem is the communication between the Pi and Windows (most likely related to the browser and the VNC software being used).

Also, the Windows Surface is a touchscreen, what about your other computer? The software that is used to connect the Pi to the PC browser is known to have weird behaviours with touchscreens - although the underscore would be a first.

Cleo

PS. did you try with another browser, like Chrome? And is your Firefox the latest version?