Left motor does not work


#1

Hi there,

Just assembled GoPiGo2, updated all FW and launched basic_test_all.py. Sent cmd: w, right motor was rotating but left was not. It seems that there is no signal on left terminal. Also tried cmd: i - and it did not work as well. Swapped motors and one that was connected to the left terminal was not rotating. So motors themselves are fine.

Is it a HW issue or SW? And how can I fix that?

Thanks.

Stan


#2

testing log:


#3

Also have never seen left/right LEDs ON during the motor test but when I turn them ON/OFF with another test that works.


#4

Hey Stan,
If you’re brave enough with the hardware, you might check that the motor connections are soldered correctly. However, if you’d prefer not, I think this might be damaged hardware. Where did you get the GoPiGo from?


#5

Hi John,

Thank you for reply. I bought it online from www.dexterindustries.com. I am quite confident with the hardware and pretty sure that there is nothing coming out from the left motor header - checked with a scope. I am just wondering if is anything I have missed and have not updated properly?


#6

Stanislav, no I don’t think there was anything wrong with the update. Are you running Raspbian for Robots or another OS?


#7

Raspbian which I got from the get-started tutorial.


#8

Ok. It looks like you already tried to update the firmware. I think the board is defective then. It must not be sending commands between the microcontroller and the motor chip. Can you reach out to us here: http://www.dexterindustries.com/contact/ and include this forum thread, and your order number? We can arrange a replacement.


#9

I already did that since nobody wanted to help me out with that. Thank you anyway.


#10

I see you submitted a ticket on Saturday. Typically we let our folks take their weekends off, I would expect you to hear from someone on Monday about a replacement.


#11

Got it, thanks.