Less Reactive Motor


#1

Hello,
The right motor is not working as well as the left one. When I tell it to go forward, the right motor spins for a while and then stops working. When I plug the right motor into the place for the left motor and vice versa, the left motor does not work well. Thank you.


#2

Hey,
Can you give the ‘f’ command in the firmware and make sure that the version is 1.2 or greater. You should also run the install.sh script in the software folder to make sure that the software is updated. We had problems with the motors in an older firmware and software but they were solved in the newer versions.

Do let us know if this solves the problem.

-Karan


#3

Hi,
How do I do give the f command and run install.sh?
Thank you


#4

Are you using Dexter Industries SD card or image or your own image?

To check the firmware version: go to the GoPiGo/Software/Python folder and run the basic_test_all example : python basic_test_all.py . Enter f as the command to check the firmware version.

To run install.sh, Goto GoPiGo/Setup Files folder: cd Setup Files/ , make the script executable: sudo chmod +x install.sh and then run the script: sudo ./install.sh .

-Karan


#5

Hey MarvelousMarvin,

Just wanted to see if you were able to follow Karan’s post?

Thanks!

John


#6

Hi,
I tried but it still stays v1.1 and the motor still does not work. Thank you.


#7

Are you using Dexter Industries SD card or image or your own image?


#8

Hi,
I used your image on my sd card. Thank you.


#9

Hey Marvelousmarvin, I think you might have an older version of the image; what date does it say on the SD card?


#10

Hi,
Sorry I haven’t been able to get back to you. I accidentally reformatted the wrong sd card when reformatting a sd card for the new raspberry pi 2. I will be getting a new one. Thank you!

P.S
I am expecting a Dexter Industries package that I ordered a few weeks back and it has not arrived yet.