Linux formatted external USB devices will not automount - fixed!

Greetings Earthlings!

Inviting @cleoqc and @mitch.kremm

I have been testing the GoPiGo O/S 3.0.2 beta, and (as I noticed in the 3.0.1 versions), there are certain issues and a sense of “brittleness”.

Most significant among the ones I have seen is the fact that a Linux format external USB device won’t automount when plugged in.

I tried a number of things and nothing worked, so I posted a message on the Raspberry Pi forums.

A number of things were suggested and nothing helped, so I tried downloading a fresh copy of Raspbian Legacy (Buster) and, Surprise! Suprise!, the USB devices automounted normally.

I tried a full update - everything worked.

I “curl’d” the sensors and GoPiGo data over it - everything still worked.

I copied my modified directories and files, including all my project data - and it still worked.

I copied over the VS Code configuration and secrets, and, (after removing the original SSD key in $USER%.ssh and re-allowing it to connect), VS Code worked wonderfully.

I then installed the new certificates, modified the host file to point to my robot, installed and configured nginx, and everything still works, including the USB devices.

I suspect that sometime during the creation of these images somewhere down the line, the automounter got messed up.  Since they don’t test with anything but FAT-32 formatted drives, they never noticed it.

Unfortunately I cannot install or test the GoPiGo O/S specific functionality - the web server, Bloxter, Jupiter, and stuff like that as I do not have the files or scripts to install them.

I have asked Nicole to consider re-packaging the new release on top of the latest Buster release.  Hopefully, this will eliminate a lot of the quirky problems I’ve seen in the past.

What say ye?


We explicitely do not support EXT4 on GoPiGo OS, nor we do support plugging in anything else but one USB drive (fat 32 formatted) into the Pi. If a user needs more than that, then GoPiGo OS is not for them.

GoPiGo OS is meant for people who are getting started, and basically in the classroom environment. We opened up the OS because some summer camps have some kids in GoPiGo OS, and some kids in the desktop environment.

If the user needs go further than that, we support installing directly to Raspberry Pi OS - where there are no limitations (well less, I guess. There are always limitations because this is a Pi, not an AI board for example).

The automounter did not get messed up, we intentionally over-ride it to support the web interface, which otherwise would not have write permissions to the drive.