Log file from "Troubleshoot GoPiGo" not showing up in Desktop


#1

Hi GoPiGo Experts,

I successfully complete mission 1 and am not attempting mission 2. When attempting to open an LXTerminal, I get:
xlib: extension “RANDR” missing on display “:1.0”

In trying to debug this issue, I ran “Troubleshoot GoPiGo.” The motors seem to work fine, but the log is not showing up in the Desktop. Any help on debugging the missing log and/or the LXTerminal issue is much appreciated.

Thanks,
Will


#2

Hello @will.flanagan
This warning is expected. It’s due to the fact that we’re running the Pi without a monitor attached to it. You can safely ignore it.

As for the log not showing up, are you letting it run its course? It’s somewhat time-consuming. A couple of minutes only but they feel really long when you’re just waiting.

Cleo


#3

Hi Cleo,

Unfortunately, I have moved a step backwards and cannot ping dex.local despite having the battery, USB, and ethernet cables plugged in and the GoPiGo powered on. I have tried multiple power cycles. The lights at the ethernet port are not illuminated.

As for the log, I was indeed letting the troubleshooting run its course. Unfortunately, I cannot re-check until I can connect to the board. Any suggestions?

Thanks for the help,
Will


#4

Just so you know you don’t need the battery plugged in. Actually all you need is the power cord plugged I’m, and if you are not using the pi3 the. You’ll need the the Ethernet.

The reason you can’t ping dex.local is because that’s the computers name, not it’s IP address. To ping it first type hostname -I Into the terminal. This will give you you’re IP address. Now add, your username, pi, with the @ symbol to the beginning of the IP address.

It should look like this: pi@xxx… etc.

That should work. If not my directions were most likely too confusing :wink:


#5

ooh, I’m sorry, this is not a good sign. It seems something went wrong with the SD card and it might be corrupt. Are you in a position where you can try to boot the Pi with a monitor attached to it? You can use a TV for that, as long as it has an HDMI port and cable. This would let us know if the SD card is salvageable or not. SD cards can become corrupt when the Raspberry Pi is writing to it and there’s a sudden power loss in the middle of the write operation.

The good news is that you can recreate the SD card and not wait to receive a new one via mail. You can follow this tutorial. It sounds impressive at first glance but the steps are simple in reality.

Cleo