Mission 3 Light Sensor


#1

I’m getting inconsistent readings from the light sensor. It worked for several tests, but now is only responding with 0.0 readings. Any suggestions or is it a bad sensor?


#2

Hmm, Is it properly connected? Try reconnecting it.


#3

Are you using Scratch? If so, could you post your code here.

When running Scratch, there is a background window in the back (aka a terminal window). Can you check if it gives errors?
Thank you
Cleo


#4

The instructions for Mission 3 say to connect the light sensor to either of the I2C ports, while the illustration that comes with the Mission points to either of the AD ports. We have tried to connect the light sensor to both I2C ports, but it does not appear in the dropdown menu of either port. When we connect the light sensor to the AD1 port, we seem to get a reading (in the 55 range) but that does not vary even when GoPiGo is in a completely dark closet. What is going on and how do I fix it?


#5

Hello @JJHuggins

The confusion may come from the fact we switch from one light sensor to another.
Do you have this new light sensor ? If so, this one goes into the I2C port.
If you have this old light sensor or one that looks very similar to it, then it goes into the AD 1/2 ports.

Hope it helps!
Cleo


#6

We have the new light sensor. When we plugged it in to either I2C port there was not a “light sensor” option displayed in the picklist???

John J. Huggins
(303) 949-7010


#7

Also, does it matter which side of the new light sensor points up, or which side we plug into? Thanks! John

John J. Huggins
(303) 949-7010


#8

Which version of DexterOS are you using?


#9

Where would I find that? The only version information I can see is on the main bloxter.com screen, which has a very small line across the top that says “Connected to GiPiGo” on the far left side and “V1.1.1” on the far right side of the screen…


#10

Hello @JJHuggins

That would be version 1.1.1 indeed. And the new color light sensor was integrated within Bloxter starting with version 1.2
This explains why you’re not finding the sensor in the dropdown menu,

You will need to update to the latest version by following these instructions.

Hope this helps,
Cleo