Moisture Sensor - Not running?

Hello!

I have the moisture sensor plugged into a GrovePi + on the analogue port. Had all the other sensors running thing (humidity, temp, light) however when trying to run the sample script for the moisture sensor, nothing is returned. It’s sort of like the script just hangs.

Updated firmware and no change.

Any ideas? Faulty sensor?

Small update.

Turns out some parts of the grovepi were not enabled. Doing: avrdude -c gpio -p m328p seems to have worked. However now I have a new problem.

I want this python script I’ve generated to run in headless mode and run on bootup. To do this I edited the rc.local to tell it to run at boot, which works fine, sort of!

The trouble I have now is that the red-reset light always appears on boot up. I tried to add the above command to rc.local as well, but it doesn’t seem to chime in on time for the script to crash because it can’t recognise an analogue sensor. Any ideas?

Perhaps Try starting with a cron @boot entry?