Motor always running


#1

My GoPiGo has been working fine for several weeks, but yesterday when I turned it on the right wheel immediately start running at full speed. The wheel just keeps turning while the PI is booting up. Once the PI is booted, I try running the basic script and using the command ‘x’ to stop it, but all I see is an IOError, and the wheel keeps turning.

The only to stop it is to unplug the wires going to that wheel’s motor. Any ideas on what is going on? I’ve tried reconnecting the PI to the GoPiGo board a few times, and checked for anything that might be causing a short.


#2

Hey jprideaux,
That’s interesting, never heard of this before. What version of the Pi are you using?

If you take the Pi off, and you power up the GoPiGo, does the wheel turn constantly (with no Pi attached)?


#3

Hi John,

I’m using a B+, and it used to work just fine. If I remove the PI board, and turn on power to the GoPiGo, the wheel still turns constantly. Seems like maybe something is shorted, but I don’t see anything visually wrong with the GoPiGo, so maybe a glitch in the PROM.

Thanks,
-Jason


#4

Hey Jason,
Can you run sudo i2cdetect -y 1 with the GoPiGo connected to the Raspberry Pi and post the output here.

-Karan


#5

Could the firmware have been corrupted on the GoPiGo board? Is it possible to disconnect the motors (just the wires) and run the install script again?


#6

Using the PI for another project in class right now, so will have to get back to you later on running the i2detect command. I really don’t think it has anything to do with the PI, though. With no PI plugged into GoPiGo board, if I turn on the power switch on the GoPiGo board, the motor immediately starts spinning. Does the install script push firmware to the GoPiGo board, or does that PROM chip have to reflashed some other way?


#7

The fact that it runs when the Pi isn’t attached means it’s probably a problem with the GoPiGo board and most likely the firmware on it.

The install script pushes new firmware onto the GoPiGo, rewriting the firmware on the atmega chip. Just be careful to remove the motors before you run the update.

Let us know what you find!


#8

Finally had some time to work on it. I turned on the GoPiGo with the PI connected and unplugged the motor so it wouldn’t keep going. I did a new clone of the git repo, and ran the install script. The scripted seemed to execute just fine, no errors and it restarted the PI when it finished. Plugged the motor back in, and it immediately start running again.


#9

So, is it running properly or are the motors still spinning continuously.

-Karan


#10

Not properly. The motor runs continuously with or without a PI plugged into the GoPiGo. I have 4 GoPiGos for my class, so I tried swapping in a motor from a working one, same problem. I then tried swapping in a atmega chip from a working GoPiGo, but still have the same problem. It seems like maybe there is a short on the GoPiGo, but I don’t visually see anything wrong with the board.


#11

Hey,
Can you try swapping the motor driver to see if that works well. Also, can you check with a multimeter if the power lines are shorting.

-Karan


#12

Hey Jason,

It sounds like there is some problem on the board. It might be something simple we’re overlooking. Either way, we should probably get you up and running as quickly as possible.

Can you contact us here:
dexterindustries.com/contact.html

We will arrange a replacement and try to get the board back so we can troubleshoot it.

Thanks, and thanks for your patience.

John


#13

Ok, I’ll use that contact form. Thanks,
-Jason


#14

https://discourse-cdn-sjc1.com/business5/uploads/dexterindustries/original/2X/f/f341cb28bc200488256b578283335f9e74db7439.movHi, I just received my gopigo 3 today and also having the same issue after first trial test. Using bloxster command robot moving forward in 1 second, one motor has stop after 1 second. However the other motor keep running after 1 second and rotation speed is abnormal. I need to manual trigle stop command the motor just can stop.
I tried swap two motor cable and plug in the abnormal motor to the normal motor slot. But the abnormal rotation still persist on the same motor.
Anyone know what’s going on ?