Motor buzzes but doesn't move


#1

I just got a GoPiGo, set it all up as per the instructions. Got the GoPiGo software using “git clone …” and updated the firwmare to 1.1. When I run basic_test_all.py and try moving forward only one of the motors moves. Same for motor_fwd(). If I disconnect the good motor and put my ear close to the one that doesn’t move I can hear it buzzing/humming. So it is connected and seems to be trying to move, but not succeeding. I tried swapping the motors and the good motor still works and the bad one still doesn’t. So I suspect that the GoPiGO is all fine and there is just something wrong with that motor itself.

I read through http://www.dexterindustries.com/forum/?topic=power-supply-issues and even tried the set_speed(150) suggested in there, but I think my problem is a bit different, since it never worked at all, even in basic_test_all.py.

So do I need to replace the motor or is there something else I can try first? Do you know the manufacturer and model number of the motor? Perhaps I can buy one of those separately.


#2

It sounds like the motor is damaged. So we can replace this asap, can you please contact us through our website?

http://dexterindustries.com/contact.html


#3

OK, thanks for confirming it. I bought the GoPiGo from Generation Robots (since I’m in France) and I’ve already contacted them. They just replied saying that they haven’t received spare parts for GoPiGo yet. I’m guessing you can’t send the motor to me any faster than to them, so I’ll just have to wait until they receive those spare parts.


#4

Same thing here. I had to follow your instructions to out the dexter industries image on the flash card properly (i bought the sd card with the whole package but it never started into the GUI) so now I wanted do start testing the GoPiGo.
Now one Motor runs sometimes but the other one just buzzes or simply does nothing at all. Movement is only possible if i want to let it take a turn as the left motor then rotates…forward, backward, turn left = no reaction.

Shall i re-flash the sd card or do you have any other advise?

thank you!


#5

I’m sorry please nevermind my last post!
I had the motor cables mixed up!
I’m now at the point where one motor stalls-so i will check that post :slight_smile:


#6

Good, glad it worked out. Before I close the post, just a quick link to this, where we’ve solved the motor buzzing and moving issue. Here:

http://www.dexterindustries.com/forum/?topic=gopigo-motor-not-working-one-starts-another-doesnt