Motors not working properly


#1

Hi Karan

Thanks for the quick reply. I am attaching 3 files:

  • output for encoder test for v15
  • output for encoder test for v13
  • my bash history showing the command I ran

The GoPiGo/Raspberry Pi are powered with the battery only, always on the ‘On’ position. Batteries are freshly charged. Note that the voltage reading is different from v13 to v15.

Hope this helps. --Max


#2

Hey Max,
Are the encoders connected to the motors and is the paper still pasted on them.

-Karan


#3

The encoders are connected… I could not see any paper on them. I am attaching 2 pictures which might help you point to something wrong. (Note that during the test i ran the robot was not taken apart like shown in the picture but fully assembled :))
–Max


#4

Here is a link to a video showing the GoPiGo behavior while running the encoder test with firmware v13:

During this run the output was:

Ver: 1.3
10.91 V

CHECKING ENCODER READINGS
3 4
Both motors moving Forward with LED On
after 5 sec 4 5
Both motors stopped with LED Off
None after stop cmd 4 5
None after 2 more sec 4 5
Both motors moving back with LED On
after 5 sec 0 0
Both motors stopped with LED Off
None after stop cmd 0 0
None after 2 more sec 0 0

CHECKING ENCODER TARGETING

Initial encoder read vals: 0 2
Enc tgt Status: 1
Enc tgt Status: 0
Final encoder read vals: 3 4

Initial encoder read vals: 0 1
Enc tgt Status: 1
Enc tgt Status: 0
Final encoder read vals: 3 5

Initial encoder read vals: 0 -1
Traceback (most recent call last):
File “encoder_tgt_complete_test.py”, line 66, in <module>
enc_stat=read_enc_status()
File “/usr/local/lib/python2.7/dist-packages/GoPiGo-0.0.0-py2.7.egg/gopigo.py”, line 519, in read_enc_status
st=read_status()
File “/usr/local/lib/python2.7/dist-packages/GoPiGo-0.0.0-py2.7.egg/gopigo.py”, line 511, in read_status
st=bus.read_byte(address)
IOError: [Errno 5] Input/output error


#5

Hey,
Thanks for the results. Are you facing any other problems apart from encoder targeting? We are trying to replicate this problem at our end and will get back to you shortly with the solution.

-Karan


#6

So far i only try to run the Basic Robot Example. Let me know if there are some commands that i should run to help you replicate the issue.

Thanks.


#7

Forgot to add that the basic_robot.py is also failing with the same behavior: when entering the fwd command the wheels motion only last for a sec and then stops while it is expected to keep on rotating.


#8

Hey,
Thanks for the information. We’ll try out the basic robot example too and get back to you in a bit with a test code to try out.

-Karan


#9

Any news on your side guys, I still cannot run the Basic Robot Example.

Thanks. --Max


#10

Hey Max,
Sorry for taking this long to reply back. I have split this tread to another topic so that it’s easier to follow and respond.

Can you make sure that the firmware version is v13 and then try out the w,a,s and d commands f with the basic_test_all.py and if it does not work well, it would be great if you could send a video of how it behaves. Can you also try powering the motors with a 6-9V power source just to make sure that they work properly.

-Karan


#11

Hi Karan,

Sorry for the late reply but i did not have time. I did the test you mention and uploaded the video :

I don’t know how to do the ‘powering the motors with 6-9v power source’ since the only way to plug them is to connect them to the board.

Let me know. --Max


#12

Hey Max,
The motors look fine to me, so does the firmware. Can you do one last test on it. Remove the GoPiGo directory from folder and make grab a fresh copy of it from the github repo. Use this on Desktop: git clone https://github.com/DexterInd/GoPiGo.git . Once this is done, go to the Software->Python folder and run sudo python setup.py install and then try the basic_test_all script to see if it’s any better. We have made a lot of changes so this might help you get the GoPiGo to work.

-Karan


#13

It looks like it’s working! will run more test in the next few days! Thanks for your help. --Max


#14

Some good and bad news.

The good news, i managed to get the motor continuously running using the basic_test_all program only in the case where the only source of power is the Raspberry Pie wall power adapter. The voltage indication is around 4.14v. As soon as I turn on the GoPiGo battery, and send the forward command, the motors starts fast for a fraction of a second and stop immediately. (note the power reading in that situation is 11.3v). I am suspecting that the GoPiGo controller crashes because when reading the encoder value (with a separate small program of my own) they get reset to 0.

This is contradicting the information from http://www.dexterindustries.com/GoPiGo/1-assemble-the-gopigo/assemble-gopigo-raspberry-pi-robot/ which states that the motors should not work when the only source of power is the Raspberry Pie Wall Adaptor.

Can you advice what the next step should be?

PS: the firmware is still version 1.3


#15

In order to do more tests, this time i hooked up the GoPiGo with a 9V battery (the samll rectangular one). When running the basic_test_all.py test, the GoPiGo is crashing less often… ie when typing ‘w’ sometime the motor runs for extended period of time and sometimes for just a burst.

This seems to indicate some kind of failure on the controller board to control the power.

Please let me know what you think and if you need more info. --Max


#16

Hey,
It really looks like you received a broken GoPiGo. Thanks a lot for testing it out. I’m really sorry for the frustration.
Can you contact us here, under “General Questions and Feedback”: http://www.dexterindustries.com/site/?page_id=65. We will have one shipped to you immediately.
Again, I’m really sorry to hear about this; we’ll make it right immediately.
-Karan