Motors start then stop on fwd()[SOLVED]


#1

Hi, I have a GoPiGo version 1 (no red velcro strap over battery pack) purchased about a year ago that I finally got around to trying to set trim.

I followed the instructions on this page: http://www.dexterindustries.com/GoPiGo/programming/python-programming-for-the-raspberry-pi-gopigo/add-trim-to-the-motors/ to update the firmware (looks like it pulled v1.6) and also updated the gopigo.py library as described. Both those scripts ran just fine.

However, now when I run basic_test_all.py and give the ‘w’ to move forward, the robot only moves a few centimeters, then stops without my pressing ‘x’. Same with backwards.

Any ideas? Is the GoPiGo version 1 able to run firmware v1.6? Is there a way for me to flash back to an old firmware version to try that?

Thanks!


#2

Hey Alan,

The GPG1 should be able to run the latest firmware. Can you try to update it again; do you get any error messages when you do? Also, are you disconnecting the motors when you run the update?

John


#3

John, thanks for the quick response, and on a weekend no less!

Glad to hear the update should work on both GoPiGo versions.

Yep, I always disconnect the motors before an update. I did that again, as you suggested, and the process completed without errors. I also put a brand new set of batteries in, just to rule that out as a possibility.

hardware_test.py and basic_test_all.py now seem to function normally, so I think I’m good. I’ll let you know if I run into any more roadblocks.

Thanks again!


#4

So glad to hear that the problem is solved! Excellent!