Motors/wheels can turn in place, but won't go forward/backward


#1

I just assembled my GoPiGo. On the initial test, it veered a bit to the right, which appeared to be the result of a slightly non-flush motor/wheel assembly. I disassembled the relevant components and re-assembled, but when I ran the test, the robot didn’t move. I just get a humming sound coming from the motors. There doesn’t appear to be any mechanical issue, since both wheels are happy to spin in opposite directions when I run basic_test_all.py and turn in place; left and right both work. But when I try to get the wheels to move in the same direction, forward or backward, I just get the hum and no motion. Thoughts?


#2

Hi @jonathan.rein,

Can you follow this guide, generate a troubleshooting log and post it with your reply. Can also you tell us what kind of power supply you are using. A video of your problem with the commands that you use will be of great help in understanding the situation.

-Shoban


#3

The log file is here.

A video of the problem is here. I’m not sure what was going on with the turning command aborting on its own toward the end of the video; it wasn’t doing that yesterday. But a regular turn command spinning only one wheel continued to work as normal.

I’m using the 8 AA 12V power supply that shipped with the product.


#4

Hi @jonathan.rein,

It looks like the motor connections might be mismatched. In the video it looks like the black cable of one motor and white cable of another motor are connected together to a motor port. Can you double check the connections and make sure it is as shown in the image below.

If you still have problems after this, please let us know.

-Shoban