Need help troubleshooting wifi[SOLVED]


#1

Hello all! Just got my GPG2 all set up, and I’m having trouble with the wifi connection. I’m on a Windows 7 machine, usually wired to the router. My computer doesn’t have a wireless dongle at the moment, and this shouldn’t need one, but I figured I’d mention it.

Ok, so:
I got to the step after configuring wifi where you shut down the bot from the VNC dashboard and disconnect from the computer. Bot reported address of 10.0.0.6

  • Lights on the bot never go off. I waited several minutes here.
  • Tried turning off the bot, unplugging, and turning it on: computer (back on the network) could not ping dex.local - Got a timeout. Could ping 10.0.0.6

Looks like I need a static IP - could I get a step-by-step on doing that? My setup is currently as such:
my computer – a basic switch – a router(1) – another router (2) (sorry, it’s a big house) – cable modem – internet

Pinging does work between the bot and this site when the bot is ethernet connected to my computer, which is not otherwise on the network. Therefore, the wifi connection to router(1) and thus out is working. However, when I put my computer back in place on the network, it cannot see dex.local - however, it does see a computer named DEX on the windows network map, and doesn’t know where to put it on the map (in case that matters).

So, how do I enable this computer to find and talk to the pi by name? We’re looking to use this in a classroom with several bots each controlled by its own laptop but on the same wifi network - and feeling a bit lost.

Thanks for the help,
Stella


#2

I think you’re good to go, using the “dex” name. The “dex.local” name is specific to the Ethernet-cabled connection between the robot and (desktop?) computer.

Try opening a browser, and browsing to “http://dex” — if that doesn’t work, try browsing to “http://10.0.0.6”. One or both of those should take you to the robot’s initial web page, from which you can click on the big VNC block to make a GUI connection.


#3

Hi, I’m working with Stellapacifica on this. We’ll try that, but I think we actually got further than this before we hit the problem. Thanks!


#4

Sure enough, just logging in with dex worked. Thanks!


#5

Glad to hear it. Have fun with the robot!


#6

Learn something new every day! I have never tried connecting without the .local, but it works! Woah. Mind blown…
Question for StellaPacifica, if you don’t mind. On your Windows computer, do you have iTunes installed? iTunes comes with Bonjour, which is what’s needed to recognize http://dex.local

And thanks for the tip, bloomu.prof!