New User - Initial Update to GrovePi[SOLVED]


#1

Greetings! Just received my GrovePi (RPi 3) and got it up and working no problem on wifi. Using VNC to connect and run through the update procedure and I get to “sudo git merge origin/master” from the Desktop/GrovePi directory. I keep getting “your local changes to the following file would be overwritten by merge: Software/Python/grove_electromagnet.py”. Please commit your changes or stash them before you can merge. Aborting.

Naturally, I have not yet made any changes to the file. I decided, hmm, I’ll just delete it. Yeah, no joy. Even though ls no longer shows the file, I continue to get the SAME error!

I’d rather not go on and run the firmware update till I know the merge completed successfully.

Any hints? (BTW - some Rpi knowledge - I’ve built/use/own six or so. Some linux knowledge, but only brave because I know I can just rebuild. No Dex knowledge - yet!)
Thanks so much…


#2

Hmm… The instructions I was following are found at: http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/setting-software/
and there’s another set here: http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/

The second set is more ‘automated’. Which is newer?


#3

OK, well, I’m impatient, so I performed the more ‘automated’ update. Completed fine!

Couple of things: the update app interface is different than the one shown in the video - might confuse some folks. And I’m not sure if I need to do the firmware update. The update app in the video shows a separate button for updating firmware, mine does not. My update app had a ‘software’ update button, a dropdown for bot selection and a ‘bot update’ button.

Has the firmware been rolled into the software update in this version? Just a thought, you might want to add version numbers and/or dates to the UI of the app. Pull it from a config file or something to display to the user. That way, if we’re presented with multiple instructions sets, like seems to be the case here with these two web pages, we can see what version is on the page/video and what version we’re using and know if our version is later. I say that because if my version is later than the one I’m being shown in the instructions, I’ll just assume the video has not been updated and go ahead with the update app. The way it is now, it’s difficult to know which is the latest instructions.

So… do I need to update firmware or did the app complete it all?


#4

Hello @bigal,

We literally just pushed this new update and haven’t had time yet to go over the documentation.
“Update Robot” is indeed the same as “Update Firmware”. You do not need to update the robot (aka firmware) unless you run into problems.

This is the new dialog for updates:


#5

Thank you for the quick reply!

That’s the dialog box I got! And nope, no problems. Everything is running over VNC without a hitch (now I’ve done it!).

Looking forward to doing some cool stuff with this! (And I just ordered an Arduberry, so you’ll be seeing a lot of me on these forums. I apologize in advance.)


#6

This topic was automatically closed after 24 hours. New replies are no longer allowed.