No ethernet lights[SOLVED]


#1

Hi there

I just got my GoPiGo that I got from your kickstarter campaign.
I carried out following steps:

1)Assembly according to your mission 1 book
2)Inserted the SD card dated with: 2015.11.09 (the SD card slot carries the number: 50515CC)
3)Connect the battery pack
4)Connect the Ethernet cable to the raspberry
5)Inserted the wifi dongle
6)Switch on the power switch – power led on green steady
7)At the raspberry there are two led’s. One red and one green. The red light appears and stays on. The green light blinks a couple of times and then stays off.
8)Connect the Ethernet cable to the PC. No lights on the Ethernet connection appears.
9)Download the bonjour print service for windows.
10)Try to ping the raspberry without success.

Then I disconnected the raspberry from your dexter module and I connected the raspberry via mini usb directly to the electricity. No change. The led’s of the Ethernet cable keep off. They never light on. Even when I try to connect the HDMI cable, there is no way to get the raspberry connected to my computer.
I rechecked the SD card slot. It clicks when I put in the card. This seems to be normal. I never took out or put in the SD card when the raspberry was energized.
What shall I do to successfully ping my raspberry?

Thank you for your help.


#2

Hey MichaelF, I’m sorry to hear about the challenges here. I have a quick question and a quick suggestion:

You wrote, “Then I disconnected the raspberry from your dexter module and I connected the raspberry via mini usb directly to the electricity. No change.” How are you power the Pi in this step? Are you using the Raspberry Pi Power Supply supplied by Dexter Industries? If not, is it a 2A power supply?

Also, I’m confused about what you’re trying with the HDMI cable. Have you tried to connect the Raspberry Pi with a monitor using the HDMI cable?

First, can you double check that the ethernet cable is slid all the way in to the Pi ethernet port and all the way into your ethernet port on your computer. Are both ends all the way in?

Second, do you have an extra ethernet cable you can try replacing the Dexter Industries ethernet cable with?

Thanks MichaelF, I’m sorry about the speed bump here!


#3

Hi there
To give you an answer to your first question: I connected the raspberry pi via the mini usb that I got from you…the power supply supplied by Dexter Industries.
Second question: Yes I tried to connect the raspberry pi via HDMI cable to the monitor of my laptop. But the raspberry pi was not detected.
I really pushed the Ethernet cable fully into the Ethernet port on my laptop as well as on the raspberry itself. No change could be recognized…no light starts to be active. I tried a different Ethernet cable together with the computer of a friend but no difference. The lights of the Ethernet cable at the raspberry pi don’t light up at all.
I read in your forum that this could be caused by this bonjour printer assistant. That it does not work properly on the windows7. How can I find my raspberry by the IP address. How can I found out its IP address if this might a possibility to solve the problem?
Or might the problem be the software on the SD card? As I mentioned before, I never took it out or put it in while the raspberry was switched on.
Cheers MichaelF


#4

Hey MichaelF,

Ok, I think I have a better picture of what’s going on. I haven’t seen this before: the Pi appears to boot up appropriately (ACT blinks and the Power is steady). You seem to have everything setup correctly and working. but the ethernet lights are not coming on. That means there’s no hope of a connection with the computer, they’re simply not connecting.

If you’re up for it, I would recommend that you try to reburn your SD Card. We have directions here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/

If you look at those directions, is it something you feel comfortable trying to do?


#5

Hi there

Perfect! It worked! Thanks a lot for the fast support and the good instructions-(videos)!
Now I can get started :-)!!!

Cheers Michael


#6

Great, I’m glad we got you going. I’m sorry about the mis-fire on the SD Card!