No lights with ethernet - pc


#1

I know we are a little late to the party, but my son and I have finally started with mission 1 and have come to an abrupt stop. I looked through the forums, but can’t quite figure out how to fix our problem. We have watched the videos, and then put everything together with the included booklet. Everything has worked and gone together nicely, but when we got to ‘How to connect your computer to the GoPiGo robot for the first time. Step F (Page 32)’, we found a problem. The 2 LEDs do not blink or do anything and the computer nor my laptop recognize anything being connected. While searching for answers in the forums, I came across one that talked about the SD card. So I put that in my laptop, and there is nothing on it. It seems that this would be a problem, but I don’t know if it is related to LED problem or a separate problem. I tried to Install Raspbian for Robots Image on an SD Card, but failed in my attempt. I do not have an SD card reader on my computer, but I do on my laptop. After following the steps from the website on my laptop, I get a ‘Write Error’ message. It states, 'An error occurred when attempting to write data to handle. Error 1117: The request could not be performed because of an I/O device error. My son and I were very excited, but can’t seem to move forward. Please help. My work takes me out of town frequently, so I may only be able to address your responses every few days, so please don’t give up on us. Thanks.


#2

Hi j4ball,
If both the LED’s are not blinking at all and when you connect the SD card to computer, if you don;t see a small ~80MB disk, then the SD card is indeed blank. We can replace the SD card but that might take some time. If you have some time, it might be faster to burn it at your end. Please follow the instructions here: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/. Do let us know if you want us to send a replacement SD card.

We have seen Error 1117 before. Can you double check that notch on the SD card is not at lock position and that you are running Win32Disk imager as admin. Refer here for more details: http://www.dexterindustries.com/topic/help-with-gopigo2-setup/.

We will make sure that you are able to get the GoPiGo working ASAP.

-Karan


#3

Just to hop in with Karan on this one:

We’ve seen this error when the SD Card latch isn’t properly set, and when Win32Disk imager isn’t working properly. Here’s a quick picture to illustrate the issue with the SD Card latch:

If you’re using a PC to run win32disk imager, when you click on the icon, right click on the icon to start Win32Disk Imager and select “Run as Admin”.

Let us know how it goes, we’ll be here. Thanks for your patience and persistence!