No Mac or Windows machines with wired ethernet for initial setup


#1

I don’t have Mac or Windows machines with wired ethernet. The getting started instructions don’t cover Linux, and it’s been a decade or two since I’ve done any serious linux networking and I’m stumped.

I’ve tried connecting via ethernet cable and another raspberry pi, but I can’t come up with the relevant commands. I tried setting eth0 to use dhcp but the landscape has changed pretty significantly and search engines are failing me on what to try next.

I’ve tried plugging in a keyboard and monitor to the GoPiGo raspberry pi and nothing happens (It’s turned on, the red LED is on, the green LED sometimes blinks so it’s not broken, the Green LED on the gopigo board is on).

Any ideas what I should try next?


#2

I’ve been wondering about that too. I’ve done lots of research on google, but haven’t found much for my distro. However assuming your using debian it might be easier. I saw more tutorials on google for ubuntu. No one cares about fedora. :disappointed:


#3

Hi @nobody,

It looks like the SD card can be corrupted, since you aren’t able to seen anything with the Pi connected to monitor. To confirm this can you power the Pi with a USB cable connected to your laptop and connect your Pi to a monitor. Tell us if you can see anything on the monitor and also the status of the power and ACT LEDs on the Pi.

If you are still not able to see anything and if your ACT Led stays solid or doesn’t turn on at all. It might be that your SD card is corrupted. You can re-burn and install the image again following the instructions given here. In the instructions follow the one for Mac, it will be similar for linux systems too. You will have to download etcher for linux instead of Mac and follow instructions given there.

-Shoban


#4

Monitor: nothing. It goes into power save mode after a few seconds.
green LED on the red dexter industries board: on. no blinking
red LED on the pi: on; no blinking
green LED on the pi: turns on pretty solid at the beginning, blinks a few times, then turns off mostly with an occasional blink


#5

Are you downloading from source forge? Try getting it from google drive or try just normal raspbian to confirm what is wrong.The image from source forge is broke. I got the same issues your having @nobody