No Motor Movement


#1

Hi all, new GoPiGo user…

Everything is assembled, board updated, raspberry (model b) updated, using Dexter image. Board has power with no pi connected. Everything powers up fine with the 8"aa" power pack, new batteries, show 12.5v on meter.

Connect through Putty with wireless, no problems, run the python script, basic_test_all.py, see “cmd”, push the “w” key, nothing. No motor movement with any key input. Then tried with ethernet, same result. Have read the posts here, any ideas on getting these motors moving.

Motors wired w,b,w,b.

Glen


#2

Here’s i2cdetect with everything powered up “normally” from the “aa” power pack.

Glen


#3

Still not getting anywhere. I did read pages back that you should not take the tape off the wheel encoders, which I did. I took the tape off everything.Nowhere does it say not to take the tape off. Their pure black, why do they need tape on them?. I did try with masking tape, made no difference, the motors still do not move when the “w”, “s” keys are pressed.

Glen


#4

Just to go over again.

Power up with the battery pack, voltage is fine, 12+v, green light on gopigo board, raspberry model b boots up fine, using wifi. I can vnc to the pi desktop with no issues, from my laptop.

Firmware update seemed fine, at the end it showed ver 1.2, voltage 4.32v, I was using micro usb cable for power.

Open terminal, cd /Desktop/GoPiGo/, cd Software/Python/, execute sudo python basic_test_all.py, and none of the keys “drive” the motors, not the w,s,a,d keys or the i and k keys. There is no noise at all from the motors, no hum, no buzz, nothing. When I run the script I see “cmd” and then try the directional keys on my laptop keyboard with no luck.

Looking at the bottom of the gopigo board, the motor wires from right to left are w,b,w,b. The left black wire is close to body mounting screw beside the motor.

I’m using the image from Sourceforge, dated Feb 17, 2015, this link http://sourceforge.net/projects/dexterindustriesraspbianflavor/ .

At a loss.

Glen


#5

Ok, I’ve got it working now. I have an issue though, it only wants to spin in circles when I select forward? Back to scouring for answers.

Glen


#6

Swapped motor wires, sorted out. Now to try and get it to go straight, and control with Ps3 controller.

Glen


#7

Hey Glen,

First, I’m really sorry about the echo chamber you’ve been in the past day. I’ve been travelling, I’m not sure where Karan is, but we should have responded quicker.

It seems like you’ve made progress; what happened or changed between the motors not moving an the motors moving in circles?

I’m going to be here around the forums the next few hours trying to catch up. Anything i can help with, I’ll hop in asap. Again, thanks for the detailed description of what you did: you gave all the information we could have asked for and we came to this late.

Thanks Glen.

John


#8

Hi John,

Swapped the motor wires, that sorted out the spinning. Now to try and get it to go straight.

Got it working with a Ps3 controller, but can’t figure out how to stop?

About my issues earlier, I think it was a lack of “my” knowledge, and me missing the instruction (if it exists somewhere) to hit “enter” after a command. I figured it would work just by hitting the “w” key for forward, as an example. Never thought to hit the enter key.

I have a ton of rc stuff here, so I decided to use a 3s lipo for power, it works just fine. It’s basically the same “full” voltage as 8 AA batteries, in the 12.5-6 volt range. I’ve used it so far somewhat depleted, around 12.2-3v, no issues yet.

Would it hurt to use a full 3s lipo, 12.5-6v? Probably not if that’s the voltage of a full Alkaline pack.

I can see this being a lot of fun. I have pi cameras already, need to get some other stuff and play around.

Glen


#9

Figured out how to stop with Ps3 controller, the “x” button, makes sense.

Still doesn’t like to go straight, any help with that would be appreciated.

Glen


#10

Hey Glen,
We had PID control for the motors when we started, but it didn’t work very well for everyone so we disabled it by default. If you want to try it, just open gopigo.py in a text editor, goto line 129 and replace motor_fwd_cmd to fwd_cmd in the fwd() function. This would enable the PID on the motors when they move forward. Let us know if you try this out.

-Karan


#11

Thanks Karan,

I did the edit, but it doesn’t really go “straight” with pid on, or off. Within 3-4 ft it has probably veered 2 ft to the right, hope that makes sense. Checked the wheels and they’re not binding on the bolts that hold the motors. I need to do something about that, the bolts are too close to the inside of the hubs of the wheels. Anything else I can try to get it to go “straighter”?

Glen


#12

Hey Glen,
We were discuss this and saw this on our latest visit to a college the other day. We were considering and going to start working on a firmware update that lets you calibrate or “trim” (like trim like in an airplane) as a short terms solution. The longer term solution would be to refine our old PID algorithm so that it runs straight on any terrain, surface, or battery level.

Watch this space! We’re going to make it better!

John


#13

Thanks John,

I tried mounting the motor bolts from the outside in, meaning the nuts are now on the inside. This allows you to get the wheels further in on the motor shaft, without rubbing on the wheel hubs. It seems to have helped a bit as there’s less wobble, and it also seems to “track” better when the battery pack is fresh?


#14

Hey,
Thanks a lot for letting us know about it, we’ll update the instructions on the assembly instructions so that it’s easier for others too.

-Karan