No network on my Gopigo


#1

Hello,

The network part of my Gopigo stopped working a few days after purchase.

When I plug the network cable, the 2 LEDs stay off, both on the Raspberry and on the switch.
I can’t access the Gopigo by Wifi either.

How can I troobleshoot this problem ?

Many thanks in advance,
Julien


#2

I did some more tests.

I plusgged the Gopigo to a HDMI screen. The screen stays black.
I fear the problem comes from the Raspberry card …

Any thought ?

Julien


#3

It probably is. Easy fix though. Just follow these instructions to redo it. https://www.google.com/url?sa=t&source=web&rct=j&url=https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/&ved=0ahUKEwiL6Ib58KzSAhXoiFQKHWXeCjQQFggdMAA&usg=AFQjCNHmTlqFZBznyDZAeVSLHm0nLq4l_w&sig2=pc9rYkgYZFZWdExsTx9TsQ

You can also get your files off by just plugging the SD card in your computer and going in your files app.


#4

Hello,

You were right. installing the OS again made the network work again ! Thank you.

But now, I’m still not able to configure Wifi. As you can see in the following screen capture, the Wifi adapter is not found. When I click Scan, nothing happens.

Any idea ?

Julien


#5

What pi are you using? Only the pi3 has built in WiFi.


#6

Hi @julien,

If you have the wifi adapter provided by Dexter along with the kit, can you try removing the adapter and inserting it again on to the Pi.

-Shoban


#7

Hi Shoban,

I have a new Pi 3, bought for christmas.
And I tried to remove and insert the adapter. Nothing happens.

Are there any tests I can launch to verify the wifi network ?

Julien


#8

You can type in the terminal
ping google.com

If it works then you are on the internet. Is that what your asking?

If you have the pi3 there is no need for the WiFi adapter unless you are using cinch. Also you might have to wait a bit for the led light to start blinking in the adapter. That means it is activated.

You could also try following this tutorial by adafruit on setting up WiFi.

Hopefully it works.