No pictures. USB is being seen

I’ve gotten the error message “If you’re not seeing any photos, you need to make sure a USB key is inserted in the Raspberry Pi (green board) of your robot.” I’ve read through the forum. The Jupyter notebook sees the USB drive, and I’ve written a new text file to it to make sure it works. I’ve tried all 4 USB slots, formatting the drive, different USB drives - always get the same error. I just got the kit. I’m running DexterOS 2.4.4 to check the sensors before moving on to ROS.


Congrats on getting a GoPiGo. It will be interesting to see your bot and to hear your plans with ROS.

There are a few ROS GoPiGo3 folks lurking (I think) and a GoPiGo ROS book recently released.

Did you submit yor problem to

Welcome and let us “not quite ready for ROS yet” folks know more.

CyclicalObsessive - Alan

1 Like

Thanks. I got the book - I’ve learned a little ROS, but this seemed like a good way to have an actual robot running with it. We’ll see how it goes.

I didn’t know about the email address - I was under the impression the forum was for help. Which makes sense in that you can look up the troubles others had. Unfortunately what worked for them doesn’t seem to work for me.


Hello and welcome

I suspect your issue may be with the camera itself.
If you go into the Python section on DexterOS,

import picamera
cam = picamera.PiCamera()

Does that work?

If it does

try this in a different cell:


Thanks - I was hoping it would be something simple. I tried your suggestion - I got an error with the first cell (“PiCameraError: Camera is not enabled…”).

Since I couldn’t run sudo from the terminal (I found that thread in the forum regarding the Jupyter user password), I downloaded the Raspberry Pi OS and put that on a different microSD card. I was able to SSH into the Raspberry Pi, confirm that the camera was enabled in the new OS, but the camera wasn’t detected with that OS either. I’ve triple checked the connections - they seem to be fine.

Lastly, I’ve tested the camera on a different Raspberry Pi using a different connecting cable I had lying around, just to make sure it wasn’t the connecting ribbon. Camera wasn’t detected on that one either. I’ve had problems in the past with the little micro-connector above the lens coming loose, but I’ve checked that as well.

So it does seem to be the camera itself.


Strongly suggest the Raspian for Robots OS for your initial familiarization with GoPiGo3 platform. It doesn’t have the bloxter environment, but it seems you are already adept with coding non-graphically.

What sensors are you planning?

1 Like

The Raspberry Pi OS was just so I could quickly check the camera. Once I get to ROS I’ll use whatever is recommended.

Distance sensor, IMU and camera for sure. Haven’d decided on the others.


(With battery voltage, processor load, and wheel encoders ) those are the suite my bot is using or in the process of putting to use.

There are two folks recently that have a 360 LIDAR-Lite, which seems like ROS standard configuration.

I am hoping that eventually the Pi-camera and the distance sensor with the wheel encoders can provide enough information for SLAM, without the power hungry LIDAR. My bot is on a power budget so I only want sensors with a low current standby feature. (LIDAR-lite is 105ma idle, which would cut my bot’s playtime from 6 hours to 4.5 hours using 1900 mAH Eneloop AA cells now at 425 charging cycles and still getting 90% capacity.)

1 Like

4.5 doesn’t sound that bad. Also doesn’t seem like it would be that hard to use a 3S compact lipo that would have a higher capacity. I would like to get into SLAM - I wondered if there was LIDAR small enough for the GoPiGo.

1 Like


I’ve had that exact same problem. This usually means that the Pi can’t see/detect the camera itself.
A few possible reasons:

  1. Contact issues
    • Between the Pi and the ribbon cable.
    • Between the ribbon cable and the camera.
    • Have you verified that the cable is inserted correctly? (Blue side toward the brown part of the connector.)
    • Have you verified that the cable is pushed in firmly? (you have to pull the brown piece all the way up, slide the cable in, it will go in about half a centimeter deep, (1/4 inch or so), and then push the brown piece down firmly on both sides.)
  2. An issue with the ribbon-cable
    • This is less likely, but examine the ribbon cable for cracks, especially where the contacts are.
  3. An issue with the camera or Pi itself.
    • Much less likely than the other two, but possible nonetheless. I would look long and hard at other potential issues before blaming the boards.

I’ve had problems where the ribbon was just a smidge out of true, and that was the problem.

I tested several Chinese 3S LiPo varieties - none delivered to promises.

I have settled on Eneloop Pro for high capacity (true 2550 mAH for 300 cycles) or Eneloop 1900 cells for true 1900 mAH and so far 425 cycles still delivering 93% capacity.

The Pro cells are really pricey, but the regulars end up cheaper than even Amazon Basics because of cycles delivered (till 50% rated capacity).

(Plus my wife won’t allow LiPo batts inside the house.)

1 Like

Thanks. Yes, I checked connections multiple times. Also tried a different ribbon cable, and even tried it with a different Raspberry Pi board. Really seems to be the camera.


Just to close the loop - it was a bad camera. A replacement works fine.


Thanks for the update!