No Wifi on GoPiGo3


#1

Before Christmas we had wifi problems (with brand new GoPiGo3 starter kit). We downloaded the updated dexter OS and flashed it to the SD ran it, and it seemed to correct the problems (used the gopigo for about a week).

Come back from the break, wifi led doesn’t flash - no wifi. dead. nada.

Downloaded latest bloxter OS - no wifi.

Downloaded raspian for robots. Connected via ethernet from laptop to Pi. There is no “WiFi Setup” icon.

Plugged Pi directly into router (ethernet) for direct web connection, using HDMI monitor, and mouse, ran firmware and raspian updates from within Raspian for Robots. Still no wifi upon reboot.

going to keep plugging away at this but in the meantime…


#2

@casagrandedan check the pi hardware okay
sudo iwlist wlan0 scan

later try setting static ip to pi
below link can help
https://www.raspberrypi.org/learning/networking-lessons/rpi-static-ip-address/

cheers!


#3

Greetings!

This usually happens when the system cannot detect the presence of a WiFi adapter or dongle.

Questions:

  1. What are you using as your Raspberry Pi?
    (Since you’re using a relatively recent starter kit, I’m assuming it’s a Pi-3B with built-in WiFi. That’s what came with mine.)
  2. Are you and/or were you using an external WiFi dongle?
  3. If you have one, have you tried using an external WiFi dongle in place of the internal WiFi?
  4. Have you tried downloading and flashing the latest-and-greatest plain-vanilla Raspbian?
  5. Have you tried a different Pi device?

I don’t know what troubleshooting steps you’ve tried since your last posting - it would be interesting to know.

Depending on what you’ve discovered, there is the unlikely but still possible possibility that the WiFi on your Pi is dead, Jim. I bought a Pi-2B “kit” a while ago with an included Pi-Camera - which has never worked. Tried it recently on my GoPiGo - no Enchiladas for me Senior! - and it appears to be dead as that proverbial doorknob.

It would be really interesting to know what you’ve tried so far, as well as what results and/or conclusions you’ve reached.

Jim “JR”


#4

I back up Jim’s questions. Thanks Jim!

Although there’s one little thing I want to make clear: the only WiFi dongle that we still support is the DexterIndustries one we used to sell - it’s only one that we ever sold so you’d know if you have one. Other than that, we expect you to use a Pi3 or Pi3 B+.

Thank you!


#5

Working (In DexterOS).
Yes, using the Pi that came with the GoPiGo. No dongles.
Yes, I downloaded the latest Raspbian.
I downloaded the latest DexterOS (again). For the moment its working in DexterOS.
When I get around I’ll try to download Raspbian… again.
Thanks for all the input.


#6

@casagrandedan
@RobertLucian

The fact that it works with DexterOS is important. This tells us that your basic hardware is OK and that any issues you have are external to that.

DexterOS creates and configures its own “private” network and broadcasts as a “server” on that network. Ergo, everything is well known, defined, and encapsulated.

If I were doing this, I’d skip the rest of the Dexter software and go direct to the most general, plain-vanilla version of the Pi Foundation’s Raspbian software, (located at https://www.raspberrypi.org/downloads/, download that, hook up the Pi to a keyboard, mouse and monitor, and start from there.

Try to determine if you can configure, attach, and use your Pi’s WiFi using plain-vanilla Raspbian.

  • Use it like this for a while to make sure you’re not experiencing a heat build-up issue.
  • Make sure you have adequate battery power. A low or unstable power source has been the source of much grief since the first Cro-Magnon man tried to build his first 'bot out of bones, sinew, and a wooden wind-up key. :wink:
  • Check the connections to everything.
  • Try your Pi stand-alone; that is, not connected to the GoPiGo board or anything else but a keyboard, mouse, monitor, USB power supply and possibly an Ethernet cable.
    • If/when you do this, make sure that whatever power supply you are using can source a minimum of 2 amps at 5v.

Let us know what happens.

Thanks!

Jim “JR”