Noise Issues with Relay


#1

I have a problem with noise crashing the GrovePI when using the GrovePi Relay module.

I have a Raspberry Pi 3 with a Grove Pi board attached. For software I use Windows 10 IOT I connect a single relay module and am able to switch the relay on and off without issues without any load connected to the relay.

When I add a load to the relay i.e. a 240v mains lamp, the GrovePi crashes usually with the orange reset lamp illuminated. Only a power on off will address the problem. There are no other components connected only the lamp to the relay.

I have tried the following

  1. Tried three different grovepi relay modules
  2. A different Raspberry Pi ( both 2 and 3)
  3. New Grove interface board.
  4. Drive PI and Grove boards from a professional test PSU unit and not the current micro USB 2.5A 5v adapter.
  5. Updated to latest grove firmware.
  6. Drive the Pi and the 240v lamps from different 240v output sockets in the office

I have tried lower bulb wattages, screened cables. Moving location of cables etc.

I am currently at a loss as what to try next.

I am surprised that the relay output pins are so closed to the computer connectors on the Grove Relay PI connector.

Any advice as to what to try next would be appreciated. Note all other sensors work fine including g the relay without load.


#2

Hi @steven,

Could you tell us what kind of the following light bulbs are you using:

  • incandescent light bulb

  • fluorescent light bulb - aka CFL

  • light emitting diode - aka LED


I’m asking for this detail so I can reproduce the experiment as close as possible to yours.
If you have the possibility, it would be nice to share with us a picture of your configuration(s).


Thank you


#3

The application is an egg incubator. The incandecent 60w 240v light bulb used as the heat source is on the opposite side of the box you can see the white cable doing through the box.
The mains 240v comes in on the scotch block where it is patched to the GrovePi relay.

The layout is a bit untidy but was once glued to the box. I pulled it apart to try and minimise the interference whichst testing. Note the other cables on the scotch block have no power.

Thx for your support


#4

Hi @steven,

I’ve reproduced your experiment in order to check if I get the same issue like the one you’ve got.
It has been used the example program for the Grove Relay found in our repo.


I have used the following components within the following conditions:

  1. An incandescent light-bulb which was rated at 60W @ 230VAC

  2. A GrovePi

  3. A Grove Relay

  4. Cables, one plug connector & a light bulb socket

  5. The power supply is rated at 230VAC


Here’s a GIF of the test I’ve made.

Nonetheless, the test was a success.
The test lasted for around 5 minutes. This means the light bulb continuously blinked for 5 minutes.


Regarding your experiment, I’m suggesting you to redo/recheck everything.
I think there’s something wrong in your setup that’s making your GrovePi reset itself.

I also concur that during the experiment, there was no interference between the power supply and the Grove relay.


Thank you!