Not able to access VNC anymore + line_threshold_set.py gets stuck


#1

Hello,

Recently, I lost access to VNC into my raspberry pi. However, thankfully, the Browser streaming (with Picamera) and SSH still work! In order to get my self-driving car tasks to work, I need to appropriate calibrate my line follower and right now I cannot access the Desktop setup or troubleshooting icons. I found the instructions on how to perform the line follower threshold calibration via the terminal - https://www.dexterindustries.com/GoPiGo/gopigo-line-follower-getting-started/using-gopigo-line-follower/. When attempting to run the script, it gets stuck right after ‘Press ENTER’ for setting up the White line [ see attached terminal screenshot ]. I would run the troubleshooting/test to get a log, but I’m unfamiliar with how to do this within the SSH environment.

Please let me know if you need any more information and what steps I need to take next. I look forward to hearing from you soon!

Best,
J


#2

Not sure why it’s stopping there. Maybe it just takes time??

If you want to run the troubleshooting go into the Troubleshooting directory in the GoPiGo folder and type chmod +x all_,tests.sh Then run it with sudp ./all_tests.sh


#3

Hi @jeremy.grace01,

It looks like the line sensor isn’t recognized by the GoPiGo.

As @graykevinb has posted can you run the all_tests.sh with
sudo bash /home/pi/Desktop/GoPiGo/Troubleshooting/all_tests.sh, this will generate a log on the Desktop directory, attach the logs with your reply. Also note while running the the troubleshoot program, remember to have the line sensor connected to the GoPiGo.

Another question for you, Do you see LEDs blinking on your Line sensor.

-Shoban


#4

Hi @Shoban and @graykevinb,

Attached is the log.txt file from the sudo bash /home/pi/Desktop/GoPiGo/Troubleshooting/all_tests.sh command. Please let me know your thoughts and how I need to proceed.

Additionally, I have noticed that the Pi has been running pretty HOT recently during basic connection (no training or image processing). Should I be concerned about this? Or given the size and lack of fan (cooling system), is this typical?

Thanks again,
Jeremy

log.txt (7.4 KB)


#5

Hi @Shoban,

I was reviewing the code in line_threshold_set.py and noticed that an if loop had <> within its conditional statement (see below). This doesn’t appear to be logically correct.

So I edited the script to read if val[0] >= -1: and it printed out further information pertaining to the thresholding:

I noticed that this appears to be following the else logic from the read_sensor( ) function:

Could this be the underlining issue or bug in the script? If so, what would be the appropriate correction? Or am I missing something in the Python docs concerning valid Operation values?

Please let me know at your earliest convenience.

Thank you,
Jeremy


#6

Hi Jeremy,

First of all, the condition if val <> -1 is to make sure val is not equal to -1.


So the reason for you getting bad readings (-1 values) might be because:

  1. The electrical connections on the line follower sensor are having resistive contact - which means you have to check the connectors for loose connections

  2. The line follower sensor is defective


Now, please tell/show me the following:

  1. Do the LEDs blink on the line follower sensor when it’s connected to the I2C line?

  2. Please share with us a picture showing the connections on the line follower sensor along with the GoPiGo while you’re using it - this is just to confirm that LEDs are glowing on the sensor


We want to determine whether you have a faulty sensor or if there’s another issue with it.

Thank you!


#7

Hi @Shoban and @RobertLucian,

Per your request, I went ahead and just shot a short video clip so that you could see everything in real-time.

  • I2C was enabled
  • I edited the script back to its original version.
  • The lights appear to be working properly.
  • The wire for the I2C connection was firmly placed (nothing was loose).
  • And unlike the edited version, I previously posted, nothing printed after pressing ENTER to execute the white scan.

Is there any other way to determine if the line follower is defective?
Thoughts on next steps? If it is defective, how soon could I get a replacement?

Please advise how I need to proceed at your earliest convenience.

Thanks again,
Jeremy

Link to clip:


#8

I think that link might not have worked. Here is another one:


#9

Hi @Shoban and @RobertLucian,

I was finally able to get access to the Remote Desktop/VNC. After getting in, I tried to utilize the Desktop Line Follower Calibrator Tool and for each white and black I was returned (-1, -1, -1, -1, -1). Since I have GUI access now, I went ahead and ran another Troubleshoot/Test script and the output log file is below for your reference.

Maybe this will be helpful in determining the root issue now.

Thanks,
Jeremy

log.txt (6.7 KB)


#10

Hi @jeremy.grace01,


It looks like the line follower is broken.
I’m really sorry for the frustration we might have created.

If you had bought the sensor from us, please reach out to DexterIndustries Contact Support - see General questions and feedback section.
We will have you shipped one you immediately.


If you had brought it from a distributor, please reach out to them and ask for a replacement.


Again, I’m sorry for all of this and hope this situation will get solved ASAP.
Thank you!


#11

@RobertLucian | @Shoban | @graykevinb,

I greatly appreciate your assistance. These things happen and your team has been very helpful and prompt in giving me detailed advisement. So, no worries.

I do need this ASAP though. I have submitted my replacement request to the Feedback section you provided.

I’m a graduate student and this device (along with the GoPiGo) is part of a Deep learning project to simulate self-driving car tasks - initially with a picamera and eventually the ultrasonic sensor. The line follower is, of course, needed to keep this little guy on track so that it can recognize the STOP sign and respond.

Thank you again,
Jeremy


#12

Cool! I would love to see a video of it running! (A self driving robot is on my future project list)


#13

Hi @jeremy.grace01,

We are sending you a line follower sensor ASAP.
Someone will get in contact with you and ask for further details.
Consider it done.

Also, you’ve caught my attention when you’ve said the magic phrase deep learning project.
I’ve also been recently very interested on evolutionary algorithms, so you can understand my excitement.

One idea I’ve been thinking of is to create a design of a car / creature / plane through evolutionary algorithms and afterwards couple what I get with some neuroevolutionary algorithms (neural networks with dynamically-changing topologies).

Even though machine learning is something entirely different from evolutionary algorithms / neural nets, they are quite similar in their philosophy: they both target optimization & learning.

Thank you!