Not Able To Attach Screws from Servo to GoPiGo 2[SOLVED]


#1

Recently, I bought the GoPiGo 2, and I built it perfectly fine. Now, I am having some problems with the servo motor. I have followed your instructions and I am not able to figure out how to put the screw onto the GoPiGo. Please note I am a kid, and I am not the smartest of all people. Any help would be appreciated.


#2

Did you read the instructions or watch the video? The video may give more insight on how to do it.


#3

I have read the instructions and the video. But the screw won’t go into the plastic that you attach onto the servo motor.


#4

It could be a manufacturing defect. Can you post a picture of the screw trying to be fitted into the motor?


#5

Don’t be so hard on yourself! You have a GoPiGo2 and you built it. That means you’re smart!

If you look at the slot where the screws are supposed to go in, one end is wider than the other. I put my first screw in there, and then I slide it down where the slot is thinner. I don’t have a lot of strength in my wrist so I’m having trouble with those screws too.
Cleo


#6

Hello @graykevinb, sorry for the late response. here are the photos:


#7

Cleo
I am talking about the servo motor itself, and I need this for a science project, so I need it fast. I kind of procrastinated. :sweat_smile:
Here is the other one:


#8

I take it the screw sticking out isn’t going in any farther?


#9

Agree, plus a dummy wouldn’t buy a robot kit. :wink:


#10

Is the hole deep enough for the screw? If not perhaps there is a shorter one that fits.


#11

I have tried and checked all my screws. I am pretty sure it is a manufacturing defect, because I am not able to screw it any further.


#12

are you able to screw it in without the plastic lip?


#13

No, because I need the plastic lip to put the screw in… I am talking about the three tiny pieces in the front of the plastic lip.


#14

Hey @saurishs1215, just a heads up: the smallest screw in the bag should be attaching the plastic lip. If that’s missing, we should figure out a way to replace it for you.


#15

Hi @JohnC, I think I already contacted you, and I have gotten my servo, and it works perfectly now. Thanks for all the help :smiley:


#16

Hi @saurishs1215,

Glad that you have it working now!

-Shoban


#18

#19

This topic was automatically closed after 24 hours. New replies are no longer allowed.