Not able to reach dex.local on gopigo3

I am using GopiGo3.
I am trying to follow the following instructions
But I cannot reach Rasberrian desktop or connect via putty. Basically, I cannot reach dex.local

Bonjor is installed on the laptop.

When I connect using ethernet to the laptop, the following is observed
Light next to Power on GopiGo3 is green
Wifi light is green
On Rasberry Pi, red light is solid and green light is blinking
Lights on the ethernet port are on

Ethernet status; Enabled
Sent packets are increasing and recieved is zero

I tried following the following discussion:

Which lead me to the following instructions
How to setup static IP address:
I followed the steps but could not ping the IP addess hardcoded in cmdline.txt file

Please help

From your post:

Sent and received packets should both be increasing (as stated at 1:15 point in the video you referenced).

Are you sure you don’t have something blocking you connection (firewall)? Do you have another ethernet cable you could try? Ethernet port led’s are not a 100% indicator that you don’t have a bad cable (or ethernet port).


If the Wifi LED is green, then you are running DexterOS and not raspbian for Robots.
You probably see an access point called GoPiGo instead?

Yes, I am able to access DexterOS over WiFi. But what I can do with DexterOS is limited. I am guessing that DexterOS is a layer over ‘Raspbian for robots’ and I am trying to bypass DexterOS.

If you want to switch from DexterOS to Raspian For Robots, you’ll have to reload your SD card.

Instructions here:


What a coincidence. Inpired by Can't connect Computer to GoPiGo3, I read the article you suggested and tried it earlier today (on a different SD card) without success (dex.local is still unreachable).
I tried different laptops and ethernet cables, but seeing no bytes received on ethernet.

Today I loaded a spare SD card with the newest Raspbian for Robots image (2018.06.27_Raspbian_For_Robots_by_Dexter_Industries-stretch.img). Just loaded the image - did not chang any other configuration.

Put the SD card in my Raspberry Pi, connected the Pi with an ethernet cable to my local network (Pi, Win10-PC and Mac all connected to the same ethernet switch) and booted the Pi and I’m able to connect to dex.local from my Win10-PC and my Mac.

Then I connected the Pi directly to my Win10-PC with an ethernet cable and it works fine this way also.

Then I followed my advice from the link you posted above and copied wpa_supplicant.conf to the boot partition of my SD card (file edited to contain the SSID and PassPhrase for my home WiFi network). Then I booted the Pi with no ethernet cable connected and I can connect to dex.local over my home WiFi.

Are you sure you don’t have some kind of firewall running on you notebook? Seems unlikely if you’re able to connect with DexterOS but not with Raspbian for Robots. When you boot the Pi with Raspbian for Robots, do the led’s on the Raspberry Pi look normal (the ones to the side of the SD card)? The red led should be lit solid and the green led should be blinking while the Pi is booting.