Not Recognizing On Same Network


#1

I configured everything correctly as far as I know on the GPG. Updated software, firmware, and Raspbian. My wifi dongle is blinking, but I cannot connect to the GPG via wifi, dex.local, or the IP under ifconfig.


#2

Are you using the latest Dexter Industries raspbian for robots image. If not can you follow the instructions here to install it: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/. You can follow the playlist here which would help you with setting up the network: https://www.youtube.com/playlist?list=PLGXEJ4Ye1qCNZ9OGYTXh7o8jSgO5-NHjY.


#3

Can you connect when you plug in an Ethernet cable?

Do you have a WPA password set on your wireless router? I do, and I had to connect through an Ethernet cable while I configured the wifi to do WPA.


#4

I got the newest image on the site, the most updated Raspbian, firmware, etc. And yes I can connect it via ethernet. And it connects to the Wifi without being plugged in via ethernet. The issue is I cannot connect via dex.local when both my Pi and Laptop are on Wifi.


#5

I had success by connecting to “dex” instead of “dex.local” in a web browser (firefox).


#6

Can you ping dex or dex.local from your terminal while on Wifi?


#7

It’s been awhile since I tried, and I’m not near the robot at the moment. I want to say “yes” but I’ll doublecheck this evening.


#8

I cannot ping dex.local (pretty sure dex is just the same thing and it resolves .local) while both things are on Wifi. On ethernet it’s not an issue.


#9

I am new on this, but I just powered the PI with a normal power supply, reboot and I was able to connect fine. This, because I had my 8 battery pack supplying a very low voltage (< 9 v.) to the Pi and the WiFi dongle then was not working properly. Replaced my “new” batteries with other set of new batteries, problem solved. Hope it helps.


#10

I am using a power supply when running it.


#11

Also I just remembered that I had to reboot my router after playing with different WiFi dongles on the GoPiGo.


#12

Hey @theadarbutel,
Which model of the Raspberry Pi are you using and which wifi adapter are you using. Can you connect to the Pi via Ethernet and run ifconfigand iwconfig on the terminal and post what you see there.

-karan


#13

@karan, I’m using the Model B+, with this wifi dongle.

iwconfig gave me command not found. Here is my ifconfig.


#14

Hey @theadarbutel,

It looks like you have run the ifconfig command from your Mac terminal instead of the Raspberry Pi.

You mentioned earlier that you were able to connect to Pi via the ethernet so login to Raspberry Pi using ethernet first. Then make sure you configure the wifi from there. If you have trouble in configuring follow the instructions given here, then run the commands
ifconfig
and
iwconfig
on the Raspberry Pi terminal. Please post a screenshot of what you see there.

Also, it might help if you can post a picture of your Raspberry Pi setup.
-Shoban


#15

#16

Hey @theadarbutel,

Looks like you have not connected the Pi to Wifi access point, Connect the Pi with Ethernet and follow the video here to connect the Pi to the internet.

Do let us know if it works
-Shoban