NoVNC


#1

FWIW, my GoPiGo SD card shipped with a blank hostname. This breaks bonjour.

`pi@(none) ~ $ ls -l /etc/hostname
-rw-r–r-- 1 root root 0 Nov 10 11:54 /etc/hostname

Setting the hostname (instructions here: http://www.dexterindustries.com/howto/change-the-hostname-of-your-pi/) got my bon jour working correctly. I recommend at least checking to make sure your hostname is set.

UPDATE: Even after getting bon jour working I still couldn’t get vnc working (specifically NoVNC, connecting directyl with a VNC client worked fine), so I ended up pulling down the latest “Robots for Raspberry” image (see: http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/) and installed it. I wish I had captured the version I was running before I re-imaged the card. The downloaded version seems to working well; hostname was set and novnc worked fine.


#2

Chobbs42, when did your ship? Was this with a GoBox?


#3

Hi John,

Yes, it was with the GoBox (USA, if it matters). I believe I received it the week of Thanksgiving; it’s been on the shelf waiting for Christmas since.

The latest image is working fine.

Chris


#4

Thanks for letting us know, really appreciate it. And I’m glad the latest image is working fine.