Office Cannon kills networking in Pi 3


#1

Hi,

I have a GoPiGo with an Office Cannon and a Raspberry Pi 3.
When I run the Office Cannon example from ~/Desktop/GoPiGo/Software/Python/Examples/Office_Cannon, it kills my wireless networking with the built-in wifi adapter from the Raspberry Pi 3. I haven’t tried other adapters yet. I’d like to combine the Browser_Streaming_Robot and Office_Cannon examples, but not having networking isn’t that great for the browser control :frowning:
The Rasbian from Dexter is up to date, and I installed the latest version of PyUSB from https://github.com/walac/pyusb, but this didn’t help.

Has anybody seen this, any tips?

Thanks,
Alex


#2

Hey Alex,
Can you try running the office cannon example with the Ethernet. We haven;t tested the office cannon with Pi3 and I think there is a possibility that the Pi might be restarting when the office cannon starts because it draws too much power. There might be additional settings which might have to be done for the Pi3.

-Karan


#3

Also: try running it with the Pi 3 connected to the micro usb cable. This may be a matter of the power dipping and dropping the network.