OK still need help connecting via ethernet cable[SOLVED]


#1

Hi all,
I finished the assembly of the gopigo last night and until now I could ssh into the raspberry pi 2. I followed the instruction on Dexter’s website line by line and still could not get to anywhere. Battery pack disconnected, powering it with a wall plug. I am using my macbook pro with the latest OSX. The Raspbian for robots is dated 2015.11.09
I have also tried 2 different cat cable with the same result.

Here is whats happening. When I plug in the ethernet cable, both lights are turned on ( on the raspberry pi ) and 1 light would occasionally blinks.
From the raspberry pi, I have connected to a monitor and keyboard. On the top menu bar, it is showing eth0 configured with the address
169.254.236.137

I can ping this from my mac, but when I type in ssh pi@raspberypi.local
I get something like unresolved host.
Then I try to ssh via ip address: ssh 169.254.236.137 it ask for password. I have tried raspberry and robots1234 both got denied.

I verified that the sdcard is fully inserted and the cat cable also fully plugged in. With the raspberry connected to monitor and keyboard everything boot up fine and as mentioned above, I could see the configured eth0 ip address.

I also tried using my ubuntu notebook and with the same procedures performed, I cannot even ping 169.254.236.137
at least my macbook pro could go further.

I am not sure how to go on.

Please provide assistance.

Thanks,
Anthony


#2

Hi Anthony,
The image uses the hostname as dex.local instead of raspberrypi.local. Can you try ping and SSH to this hostname and see if that works. The password would be robots1234.

Please do let us know if this helps.

-Karan


#3

Hi Karan,
I am able to ping dex.local. When I ssh dex.local the passord robots1234 still get the Permission denied after 3 tries.
Please see the attached screen shoot.

Please let me know what is the next steps you want me to do.

Thanks,
Anthony


#4

Karan,
My issue has resolved. I ssh pi@dex.local instead of ssh dex.local

Thanks for the fast response.

Merry Christmas.


#5

Hi cheok,
Glad to hear that it worked for you.

Happy holidays,
Karan