Older Tornado version


#1

How can I change my current Tornado 5.0.2 version to an older version (4.5.3)? Thank you


#2

How about:

pip uninstall tornado && pip install tornado==4.5.3

Or if you’re using python version 3.x replace with:

pip3 uninstall tornado && pip3 install tornado==4.5.3

Answer ‘y’ when prompted to proceed, should uninstall whatever version you currently have installed and then install the specified version (4.5.3).

-Kevin


#3

Thank you very much. When I tried both suggestions they came up with similar error messages:

**Exception:**
**Traceback (most recent call last):**
**  File "/usr/lib/python3.5/shutil.py", line 544, in move**
**    os.rename(src, real_dst)**
**PermissionError: [Errno 13] Permission denied: '/usr/local/lib/python3.5/dist-packages/tornado-5.0.2-py3.5-linux-armv7l.egg' -> '/tmp/pip-ve1y0dx_-uninstall/usr/local/lib/python3.5/dist-packages/tornado-5.0.2-py3.5-linux-armv7l.egg'**

**During handling of the above exception, another exception occurred:**

**Traceback (most recent call last):**
**  File "/usr/lib/python3/dist-packages/pip/basecommand.py", line 215, in main**
**    status = self.run(options, args)**
**  File "/usr/lib/python3/dist-packages/pip/commands/uninstall.py", line 76, in run**
**    requirement_set.uninstall(auto_confirm=options.yes)**
**  File "/usr/lib/python3/dist-packages/pip/req/req_set.py", line 346, in uninstall**
**    req.uninstall(auto_confirm=auto_confirm)**
**  File "/usr/lib/python3/dist-packages/pip/req/req_install.py", line 754, in uninstall**
**    paths_to_remove.remove(auto_confirm)**
**  File "/usr/lib/python3/dist-packages/pip/req/req_uninstall.py", line 115, in remove**
**    renames(path, new_path)**
**  File "/usr/lib/python3/dist-packages/pip/utils/__init__.py", line 267, in renames**
**    shutil.move(old, new)**
**  File "/usr/lib/python3.5/shutil.py", line 556, in move**
**    rmtree(src)**
**  File "/usr/lib/python3.5/shutil.py", line 480, in rmtree**
**    _rmtree_safe_fd(fd, path, onerror)**
**  File "/usr/lib/python3.5/shutil.py", line 418, in _rmtree_safe_fd**
**    _rmtree_safe_fd(dirfd, fullname, onerror)**
**  File "/usr/lib/python3.5/shutil.py", line 438, in _rmtree_safe_fd**
**    onerror(os.unlink, fullname, sys.exc_info())**
**  File "/usr/lib/python3.5/shutil.py", line 436, in _rmtree_safe_fd**
**    os.unlink(name, dir_fd=topfd)**
**strong textPermissionError: [Errno 13] Permission denied: 'top_level.txt'

Thank you


#4

Sorry for the bad info, the commands I provided worked on a plain raspberry pi I have stretch installed on (without raspbian for robots).

You can overcome the permission errors by running:

sudo pip uninstall tornado && sudo pip install tornado==4.5.3

Or if you’re using python version 3.x replace with:

sudo pip3 uninstall tornado && sudo pip3 install tornado==4.5.3

I tried these commands on my GoPiGo3 and they worked without errors (without sudo, I got the same errors you posted).


#5

Thank you very much- it worked very well.