One Motor always running


#1

Recently setup my GoPiGo. Everytime I connect the motors one of them starts up right away. This started happening before I even connected the Raspberry Pi and continued after connecting the Raspberry Pi.

I have tried updating the GoPiGo firmware (with the motor disconnected) but get errors from avrdude:

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

I’ve read a couple similar posts in the forums, but did’t see any resolutions for this problem. What can I do get get my GoPiGo up and running?


#2

Hey jindell,
We haven’t seen this problem before with the GoPiGo. Just wanted to ask a few questions:


#3

It’s been doing this since I bought it. The first time I powered everything up, with the Pi connected the motor started as soon as the power was turned on. I disconnected the motors, and started investigating. Decided to try the DI Software Update (with the motors disconnected). DI Software Update fails with the avrdude error listed above. (Which is the same as the output from the sudo avrdude you requested, see below.)

I’m using 2015.03.20_Dexter_Industries_wheezy on an SD card that I created.

sudo i2cdetect -y 1 outputs:
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – -- – -- – -- – -- – -- – -- –
10: – -- – -- – -- – -- – -- – -- – -- – --
20: – -- – -- – -- – -- – -- – -- – -- – --
30: – -- – -- – -- – -- – -- – -- – -- – --
40: – -- – -- – -- – -- – -- – -- – -- – --
50: – -- – -- – -- – -- – -- – -- – -- – --
60: – -- – -- – -- – -- – -- – -- – -- – --
70: – -- – -- – -- – --

sudo avrdude -c gpio -p m328p :

avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

sudo python basic_test_all.py

Cmd: f
v -1

Cmd: v
-1 V

I’ve tried reseating the Raspberri Pi 2 B+ on the GoPiGo board. Seems to have a good connection and power is definitely passing between the two boards.


#4

One more thing. I have two SD cards that I’ve been using on this Raspberry Pi. The other SD card runs the most recently released Windows 10 IoT image. The motor has the same behavior with both the IoT and the Dexter images. As soon as I connect the motor to the GoPiGo board, it starts up right away.


#5

Hey jlindell,
Does the Green power LED on the GoPiGo turn on when you power the board and can you just double check if the GoPiGo is mounted correctly on the Raspberry Pi GPIO pins. It would be great if you could post a few pictures of your setup.

If this does not work for you, then it appears that we shipped you a defective GoPiGo. Can you contact us through our contact page for a replacement, under “General Questions and Feedback”http://www.dexterindustries.com/site/?page_id=65 and also mention a link to this discussion. I’ll also let the team know about this and we’ll send you a replacement ASAP.

I am sorry about it. We’ll try to make it right ASAP.

-Karan


#6

Karan,
Thanks for looking into this. Yes, the green LED is on. It’s difficult to see the LED in the attached photos because I had to use flash in order to get a decent pic.

I think this is correct, it seems to match the pictures on DI’s website (in particular http://www.dexterindustries.com/wp-content/uploads/2014/10/931-3.jpg )

Did you want me to try any other things, or shall I just try contacting DI via the feedback?

Thank you.


#7

Hey Jindell, does this start running without the Pi attached? If you start up the GoPiGo without the Pi attached, does it still start running the wheels?


#8

John,
Yes. I first discovered the problem while assembling the GoPiGo. Before connecting the Raspberry Pi I wanted to power check the GoPiGo. As soon as power was connected, the motor started up. I wasn’t sure if it was doing that because it didn’t have a Raspberry Pi, or it needed control software or a firmware update, so I just powered down and continued assembly. When I did the first power up with the Raspberry Pi and connected the motor it started up right away again. Disconnected and tried running the DI Software Update which fails with the avrdude errors listed above.

-Joel