One motor on GoPiGo stopped working


#1

My kid built a GoPiGo based robot for a school project. It worked great until the day of the STEM fair. One of the motors stopped working. None of the connections appear to be loose. We switched the connection on the board and it confirmed that it is the motor that is not reponding, the port on gopigo board is fine.


#2

Hi Sumit,
What was the last thing that you had tried before the motors stopped working.

Can you just double-check the wires on the motors to see that they are still soldered to the motor terminals. If that looks all right, can you try running the basic_test_all.py program in GoPiGo/Software/Python folder and give the motor commands there to see if the motors works.

If that also does not help, can you run the troubleshooting script by following the instructions here and upload the log to the forums so that we can narrow down the problem: https://www.youtube.com/watch?v=ZMadpIEYq5o&list=PLGXEJ4Ye1qCMWziVrynnrIPpgfOr-2aj9&index=4. It would also be great if you could post some pictures and the video of what you are getting.

-karan


#3

I don’t know if this will help, but i had a similar problem. As it turned out, the copper lead inside the motor housing that connects one of the brushes to one of the external leads was broken inside the motor casing. I had to take the motor apart to repair it. Test continuity across the leads with an ohm meter.