Only 1 wheel is rotating when i first power it up.[SOLVED]


#1

Hi,

When i first power up Gopigo, only 1 wheel is rotating. Is this normal?

#2

Hey Thomasleets, no this isn’t normal. What happened? What version of the GoPiGo are you using? What version of image are you using?


#3

Raspbian version 6.6. This version was updated on 2015.11.04.
Gopigo rev16_2 board.


#4

Can you try running the “Demo” first and then run the “Troubleshoot GoPiGO” from the Test and Troubleshoot Hardware shortcut from the tutorial here: https://www.youtube.com/watch?v=ZMadpIEYq5o&feature=youtu.be and do post the log and let us know how the demo goes.

-Karan


#5

Hi, i have captured the logs.


#6

Looks like the GoPiGo firmware is not wokring. You’ll have to manually update the firmware on the GoPiGo. Please go to GoPiGo/Firmware folder on the desktop and first run: sudo chmod +x firmware_update.sh and then run sudo ./firmware_update.sh. This would update the firmware. Then run i2cdetect -y 1 and you should be able to see something at 0x08. If that work out, then try the basic_test_all script to see if the GoPiGo works well for you.

Do let us know if this helps.

-karan


#7

Also, be sure to disconnect the motors before running the update script.


#8

After updating the firmware, It is working now. However, when i run the test_all_basic script, it is not moving in the direction that i command it to do.


#9

Hi Thomas,
Are the motors moving in the wrong direction when you give the move forward and backward or is the GoPiGo turning slowly towards a side. Can you give some more details about what the GoPiGo is going when it’s not moving in the right direction.
-Karan


#10

./basic_test_all.py

v1.3

Command | Expected Movement | Observed Movement

w | Forward | Rotating Clockwise
s | Backward | Rotating Counter-Clockwise
a | Left | Moving Right
d | Right | Moving Right
n | Rotating Counter-Clockwise | Forward
m | Rotating Clockwise | Backward


#11

Hey,
Looks like you have wired one of the motors in the wrong direction. I think the motor right is wired the wrong way, because when you give forward, the motor on the left and right should move forward, but the motor on the right moves back for you which is why it turns clockwise. Can you turn the GoPiGo upside down, invert the wires on the right motor and run it forward again to see if it helps.

-Karan


#12

After switching the wire, front and back is correct. However, left and right movement are opposite.

Also, when i send the following commands, the GoPiGo did not response. Is this normal?

st : Set servo position
b : Run a servo 180 degree sweep


#13

Can you check step12 here and see if you are connecting the motors properly: http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit-2/1-assemble-the-gopigo-2/assemble-gopigo-raspberry-pi-robot/. You might have swapped the connections for the left and right motors . Can you attach a picture of the motor connections to the GoPiGo and if possible a small video of it running the wrong way.

Can you also attach a picture of how you are connecting the servo motor to the GoPiGo.

-karan


#14

After swapping the motors, it is now moving in the correct directions.
Thank you.