Only one motor works


#1

I was using my gopigo everything was working fine. I did the basic robot control project and it worked great, but when I went into scratch it worked but all of a sudden only the right motor worked. I did the basic robot control project again and only the right motor worked. I shut it down went back on and the same thing happend.


#2

Hello @Ryan
Let’s see what happened here.
Can you try and swap the motors? You should be able to do so by just putting the wires into the other motor’s slot without having to take apart the GoPiGo. It’s not always possible but it’s a good test to see where the problem is if you can do it.
What were you doing when the motor stopped working, if you can remember of course.
Are your batteries weak perchance?

Cleo


#3

I’m at school right now but I was driving it around with scratch and my batteries were all just charged.


#4

I switched the wires and the same thing happened only the left motor worked. On the first post I said it was the right motor that worked but it is the left motor that works


#5

My batteries may be dead it’s doing the same thing it did the first time they died, but I just charged all of them.


#6

I fully recharged my batteries and tried it still only the left motor works. I switched the wires to the other port and the left motor was the only one that worked.


#7

I troubleshooted the gopigo I don’t know if this will help but I did it anyway. I will put the results below.
log.txt (7.3 KB)


#8

Hi @Ryan,

The test log looks good, except for one of the motors which looks damaged. I’m really sorry for the frustration.
Can you contact us here, under “General Questions and Feedback”. We will have one shipped to you immediately.

Also can you send us few images of the motor which isn’t working, so that we can inspect a little more to avoid this in future.

-Shoban