OS Upgrade = lost GrovePi


#1

Hello,

I ran into some filesystem issues after unattended power-off-on done several times and fsck was forced (unable to boot). The fsck probably fixed the issues because the GrovePi was workin afterwards.
To be on “safe side” I did update/upgrade process where after I lost connection to GrovePI.

My actual version is 4.1.13+ #826. I tried to update the GrovePI part (SW packages) as described via firmware update but the firmware update failed of course.

What is the fastest way out? New Raspbian installation? What is supported version? Jessie or Wheezy? Or is it better to use Dexter-flavor?
Any clue what to check / change? I read some articles describing other Atmega related issues after OS/packages upgrade and some forgotten files not overwritten…

Thanks for response / help!

Vit


#2

Hey Vit,
Sorry to hear the sd card was corrupted. This is an endemic problem with the Raspberry Pi.

If you want to start with a clean slate, we recommend the Raspbian for Robots. Directions on how to install that are here: http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/

Karan has a better idea about how all this works with Jessie. I think it should be possible, we’ve seen people report that it works,but we haven’t migrated Raspbian for Robots to Jessie yet.

Best,

John


#3

Hello, today I installed recent Raspbian for Robots, ran all steps / updates as stated in your instructions on web and ended with:
pi@dex ~/Desktop/GrovePi/Firmware $ sudo i2cdetect -y 1
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – 04 – -- – -- – -- – -- – -- –
10: – -- – -- – -- – -- – -- – -- – -- – --
20: – -- – -- – -- – -- – -- – -- – -- – --
30: – -- – -- – -- – -- – -- – -- – -- – --
40: – -- – -- – -- – -- – -- – -- – -- – --
50: – -- – -- – -- – -- – -- – -- – -- – --
60: – -- – -- – -- – -- – -- – -- – -- – --
70: – -- – -- – -- – --

So having 1.1 firmware I passed to firmware update but it failed with the AVR device not responding. -F makes no difference.

pi@dex ~/Desktop/GrovePi $ avrdude -c gpio -p m328p
avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.
avrdude done. Thank you.

(‘GrovePi has firmware version:’, ‘255.255.255’)

I ran full test diagnostics - please see the attached log.

So it looks like the board became somehow dead(?) in meanwhile regardless of the (not really sure connected) OS update-upgrade?

The pins are connected well, I do not see any loose joints. All sensors disconnected, rebooted few times.

What is the next step? What can I do?


#4

Hi vit,
Can you attach a few pictures of your GrovePi setup and how it is connected to the Pi.

-Karan


#5

Of course…


#6

Vin can you send one more picture from the top? When and where did you buy that?


#7

Hi, Aliexpress Seeedstudio shop, August 2014 http://www.aliexpress.com/store/1244614


#8

Looks like you are using a very old version of the GrovePi and would have an old firmware on it. Can you update the firmware on it using the instructions on the google doc here https://docs.google.com/document/d/1fe2uCjoLpAE6Vt2HS28n_dhSfbVXZ1p-hG1aEvIQSM/edit?usp=sharing and let us know if this works for you.

I also wanted to ask you when did you buy the GrovePi from Aliexpress from.

-Karan


#9

Hi Karan,

I cannot access your link - says the owner has deleted or what.

As stated it was acquired August 2014 (exactly 5th of August). The firmware was 1.1 working flawlessly.

When I try to update the firmware to 1.2.2 via standard procedure it ends with the mentioned error. (avrdude: initialization failed, rc=-1)

Thanks for help


#10

Sorry for the bad link, can you try this: https://docs.google.com/document/d/1fe2uCjoLpAE6Vt2HS28n_dhSfbVXZ1p-PhG1aEvIQSM/edit?usp=sharing.

-Karan


#11

Hello, many thanks for help - the guide solved the firmware update and afterwards it works /but my original python scripts does not, but the provided samples do work so I will troubleshoot my original ones/.

Is there any way to get GrovePi+ with specific sensors (AirQuality, HCHO, Dust, DHT Pro…) from one source? That was also my original intention buying the pack from Aliexpress / Seeed shop.

Anyway and once again thank you very much!


#12

You can buy most of the basic sensors from: http://www.dexterindustries.com/product-category/robots/grovepi/ . If you are looking for more sensors, then the best place might be: http://www.seeedstudio.com/depot/.

-Karan