Pi 3A+ not booting with dexterOS

Hi

just encountert a strange problem with my Pi 3A+ with DexterOS as it won’t boot at all.
Black screen and only the red LED is on (green one isn’t doing anything).

I tried re-flashing the sd card (32gb) with a complete new downloaded version using balena. Same problem.

I tried flashing raspberryPiOS and it works so i guess the SD card should be ok?

I had it working for months and can’t figure out whats wrong?

thanks in advance

1 Like

Are you absolutely sure the green light is doing “absolutely nothing”?  That would be amazing if that were true.

What version of Dexter O/S did you download?

Are you sure it’s a 3A+ and not a 3B+?

What happens when you power the device up with NO SD card installed?

What robot do you have the Raspberry Pi connected to?  Are you sure the pins are aligned correctly?

One other thing to try:
Take a brand new pencil with a clean pencil eraser and GENTLY clean the SD card’s contacts.  Use a Q-tip and some alcohol to wash them and then let the contacts dry.  Then try again and let us know what happens.

Well atleast i can see nothing happening. If i put in an SD card with raspiOS, the red light is on and the green one is blinking(and the pi is booting normal). With dexterOS its only the red one solid.

i tried the latest one 2.5.1 and an older one 2.4.9(the latter one worked in the past)

Yes 3A+

With no SD card inserted i have the same result.

Right now its just the naked pi ( i use it with a grovepi but not connected right now)

I tried flashing with my windowsPC and my Linux laptop, using different SD cards and different methods of flashing. Just to be sure, but nothing changes.

This is really strange to me, it was working perfectly now its not and i can’t really figure out why.

1 Like

You’ve got me puzzled. . .

“Theoretically”, that should NOT happen - even if there’s NO SD card installed, something should be blinking, if for no other reason than to tell you it can’t find the SD card!

Let me get this straight. . .

You have a SD card, we’ll call it SD card “A”.

  • If you flash Raspbian on it, it works fine and the green LED flashes as it normally should.

  • If you flash DexterOS on it, it does nothing and the green activity light does not flash at all at any time.

Am I correct?

What kind (brand, size) of SD card is it?  Where did you buy it?

If you buy SD cards from a reputable store with a reputation to uphold, chances are you’ll get better products than from some sidewalk vendor in a flea-market somewhere.

The ONLY time I’ve had boot-up strangeness like this is when I’ve used sub-standard SSD cards by strange manufacturers.

Have you tried this experiment with excellent brand cards, like SanDisk, Samsung or Toshiba (Brands like PNY and Kingston simply re-brand other people’s cards, so you don’t really know what you’re getting)

If you live in the U.S. and are near a Micro Center, their store brand SD cards are also quite good.  (Their flash drives are also good.)

I bought some cards branded “Smart Buy” and “Perfeo” while in Europe, and they were, (shall we say), “strange”.

I don’t know if this is anywhere near your problem, but good quality SD cards are an absolute must.  Nowadays I only buy top-end SanDisk Extreme cards for my Pi - They’re more expensive, but it saves me so many problems and so much grief in the long run.

=====================

Another thought:
How old are these cards?  Have they been used a lot?  Were they working before but suddenly started having problems?

You might have some cards, especially cheaper cards, that have begun to fail.

Let me know what’s happening.

Hi @karl,

Is there any reason you’re set on DexterOS? We released GoPiGo OS recently and it could fix this issue you’re having.

Take a look at the upload and the OS details here: GoPiGo Software · GoPiGo.io

Please let us know if it does the trick!

1 Like

I agree. GoPiGo O/S is vastly superior.

As someone who has used both extensively, DexterOS is a wannabe punter by comparison.

If it fits your needs, you will be much happier with it.

@mitch.kremm
Just out of curiosity, is there any particular reason why DexterOS won’t work?