Pi2 Installation issues solved


#1

Hi, I’m sharing these in the hope they help someone, and that DI might fix up their installation and instructions.

I’m installing my GrovePi on my Pi2 running Raspbian. I followed the instructions here http://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/setting-software/

After install I tried the i2cdetect test and got nothing, same with the blink test. digging in the forums turned up the missing steps.

  1. you need to : sudo apt-get install python-smbus
    [note this seems to include 12c-tools]
  2. you need to run: sudo raspi-config
    advanced->A7>Yes to enable i2c, then reboot.

After doing this i2cdetect now runs and shows 04.

Now trying to run grove_led_blink.py test (BTW your instructions need updating with the new script name) gives me a runtime error: “This module can only be run on a Raspberry Pi!”

The version of RPi.GPIO needs to be updated to work with a Pi2 - details here https://github.com/metachris/RPIO/issues/53

Steps to resolve provided by user neterlbcn:

  1. Uninstall the version that dpkg/apt-get knows about.
    sudo apt-get purge python{,3}-rpi.gpio

  2. Scan your filesystem for all copies of RPi.GPIO
    find /usr -name "RPi"
    remove everything that you find

  3. sudo apt-get install python{,3}-rpi.gpio
    to put back a good version.

I now have a blinking LED!

Cheers
netgio


#2

Hey netgio, thanks so much for this feedback. Karan and I are both working on installation scripts, and I’m reworking our image now. We’ll definitely work these into the new material.

Thank you!