Please help asap! Can't connect to University WiFi


#1

Hello, I need to use my GoPiGo in a class but now that I’m trying to log in at my University I can’t connect to WiFi. I’m fine plugged in to my laptop Ethernet, but when I scan for the network nothing shows up at all. No networks, even though I’m logged in on my laptop. I’ve tried manually entering the network name and my username and password but it didn’t work. I tried using Fing but just get hundreds of other people and my phone, nothing that looks remotely like pi or dex…


#2

A couple of questions:

  • Is your wifi dongle working? When you connect to the Raspberry Pi over Ethernet, can you "see" the wifi interface using "ifconfig" or the GUI network configuration tool?
  • Does your laptop connect to wifi okay? Does it show the network SSID ("name")?
  • Does your university require you to register a laptop before it can be connected to the campus network? (Mine does.) If so, you'll have to register the gopigo as well.

#3

University environments can be difficult to handle due to some advanced security/control issues.
It might be better to run Cinch on your GoPiGo instead of Raspbian for Robots. Your GoPigo will become a wifi hotspot that you can connect to with your laptop.
The limitation is that you can’t have the laptop connected to the GoPiGo and to the Internet at the same time (although you can connect/disconnect at will)

https://sourceforge.net/projects/dexterindustriesraspbianflavor/files/Cinch/2016.05.17_Dexter_Industries_Cinch.zip/download
to download Cinch (yes it’s a big download as it’s the complete OS)