Please help - Dead GrovePi?!


#1

Hi,
Sorry for making another thread but after trying out several suggestions commented in my post “Can’t get the Software to work”, I do now have a strong feel that my GovePi board is supposing dead.
I even tried out the Dexter image and the various tests and doing all steps updating the Raspberian, the Dexter Software and the Firmware but the ATMega Bit Avrdude seem not to respond. Nor do I have anything in the i2cdetect matrix.
Also the firmware seem not to update properly - even checking the status seem to fail.
Please help.
Gunhawk
PS: I tried to post every log file in the original Tread “can’t get the software to work”

UPDATE:
This is just to let you know that I now have opened the other GrovePi Kit I have and tested the other board successfully using the same Software setup.
This one seem to be fine and I got the HomeWeatherDisplay to run successfully with the LCD and Temp Sensor. In addition the routine displaying the firmware version does also work with this board.
As a consequence this might be the confirmation of a hardware error with the other board. Hence the firmware display/update routine does not seem to work are there any other options rather then sending the kit back claiming for warranty?

Regards Gunhawk


#2

Hi Gunhawk, where did you purchase the GrovePi that’s not working from?


#3

from ASM Technologies


#4

If you can’t re-write the firmware and you’re getting an error on this, I would return the board to ASM and ask for a replacement.