Possible broken piezo vibration sensor


#1

Hey guys,

Think I might have a defective vibration sensor. Have it plugged into the A0 port and when I run the sample grove script flicking or touching the meas film doesn’t cause the sensor to activate. The sensor is reading data but I have to squeeze where the connectors meet the film for the sensor to change to a 1023 reading
Tried adjusting the potentiometer both ways and the same thing happens flicking the film or touching or hitting it does nothing
Anyone else who may have one know if I’m using it wrong or if it sounds like it’s faulty

Was looking for a sensor I could use to detect if something was impacted by measuring vibration but don’t think this sensor will do the job even if it’s working correctly

Thanks


#2

Hi @Grim,

Can you send us a video of what you do and what you as observe as output. Moreover as you said, even if the piezo vibration sensor works, its more like detecting a vibration and it can’t be used to measure precise level of vibration, the values that you see are relative and not absolute, so they might not be very useful for measuring the vibrations.

-Shoban