Power supply issues

Thanks so much for sorting this out for us, guys! Kudos! I will be posting a video once I find the spare time to play with this robot a little more.

One little thing - one of the LEDs still does not light up. It’s a really minor issue though as the motor on that side now works and that’s all I really care about. :slight_smile:

Great to hear that it worked out. Let us know more about the problems with the LED, it should be a minor one too.

Do let us know about what you build with your GoPiGo.

Sorry for all the troubles and thanks for staying around and helping up help you out.


Karan/ Admin,

I am still struggling to get the GoPiGo to start

  • Red LEDs do not light up
  • No movement
  • 8 new AA batteries
  • Able to connect to WiFi

Very frustrating to have it all assembled and …
Please advise


Ok - Finally got it working - YEAH!!
However it keeps going in circles - what do i have to do to make it go straight?

and the 2 red leds do not light up

Can you doublecheck that both the encoders are connected properly.

If they are correctly connected, can you try running Software/Python/basic_test_all.py and give w as a command to move forward, x to stop. If the GoPiGo still keeps going round, can you try giving i as a command.

Let us know if this helps.


I’m having an issue with the power test after assembly. I’ve assembled the GoPiGo and attaching the battery leads gives no yellow LED or any sign of response. I’m able to attach the Raspberry Pi, power it and the controller with the RPi’s USB power input, update the firmware, and it tells me a GoPiGo is present and I get a green LED on the GoPiGo controller board. I’ve tried two sets of rechargeable batteries and a set of new Alkalines, but still no sign of life.
Is there something obvious I’m doing wrong?

Can you check with a multimeter to make sure that the battery pack gives a voltage of higher than 9V.

Also, double check the polarity of the connections that you are making for the connections to the GoPiGo board and don’t forget to turn on the GoPiGo power switch.

If it still does not work, can you upload some pictures of the battery pack and the connections with the GoPiGo.