Power supply issues


#1

Hi everyone,
Finally got around to assembling my GoPiGo last night. Used it with a RaspPi B+, upgraded to firmware v1.1, got wifi connectivity, and started ‘driving’ the GoPiGo around last night with the computer as well as the iPad.

This morning when I switched the GoPiGo back on, only one red LED on the GoPiGo board lit up. The motor on that corresponding side also wouldn’t work, only one wheel spins on the other side (the LED on that side lights up too). What could the problem be? The GoPiGo doesn’t move anymore since one of its motors doesn’t seem to be taking in any power.

Please can anyone advise? Thanks.


#2

Let me add that I used 8 fresh AA batteries when I set it up yesterday, and did not drive it around for more than 15 mins max.


#3

OK, sorry, trying again!

The GoPiGo moves fine just using the basic_test_all.py script.

It seems that the problem is with the Python Example code under ‘Browser Streaming Robot’. Using the mouse control on the webpage only moves ONE wheel and not the other, so one wheel just spins and the GoPiGo refuses to budge. Video streaming works fine though, but is a bit pointless unless the robot moves.

Going to have to try and debug this - if anyone has a fix for this already, PLEASE LET ME KNOW. Thanks.


#4

Hello artemisworks,

First, it’s great to hear that you got it up and running! We would love for you to share any video or pictures you have of it working.

Second, sorry to hear about the challenge with the motor movement. Since you indicate that basic control seems to work ok, it’s probably not a hardware issue. Is it possible to check that the python code wasn’t corrupted or damaged (possibly by a restart or shutdown)? Are there any differences between the code you’re running and the code up on github?


#5

Thanks for responding, Administrator!

I went to DexterIndustries/GoPiGo on github and downloaded all the code under the /GoPiGo directory (on the Pi) again and am still experiencing the same issue. I also got an IOError message while only one wheel spins and the other is motionless. The camera works fine though.

I have to power off the GoPiGo and restart it before the basic_test_all.py script will work again… rebooting the Pi itself (to free GPIO allocations) doesn’t seem to work.

Any ideas?

Has anyone else got this working, by the way?


#6

We had a firmware update just before we shipped for handling this problem. Maybe the GoPiGo that you have, missed it.

Can you run the “sudo gpg” command on the terminal. If you get the firmware version less than 1.4 or do not see anything at all, you should update your GoPiGo image and firmware. Here is the link to the update guide: http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit/5-using-your-gopigo-for-the-first-time/.

Be sure to disconnect the motors before you do this. Just makes sure that the motors are disconnected before you start or you might damage the GoPiGo.


#7

Thanks for getting back to me, Admin!

When I first set up the GoPiGo, I did what that page suggested and updated my firmware to v1.1. That’s what it said on the webpage too, so I had not realised it was up to v1.4 now. Seems like a previous poster on this forum has the exact same problem - how do we go about updating the firmware to v1.4?


#8

I think the fastest way to correct this is to connect your pi to the internet, change directory to the GoPiGo directory, and perform a git pull:
sudo git pull

Once you have the directory updated, you’ll see under GoPiGo/Firmware/ there’s a file called “firmware_update.sh”

Run this file using sudo ./firmware_update.sh

A few thoughts:
– Disconnect your motors again.
– Check the firmware version after you run it.


#9

Sorry, I replied to the other thread after I found the instructions there.

Did as you said exactly, and it STILL says the firmware version is 1.1.


#10

Hey folks, please standby. We’re trying to figure out the problem. Unfortunately both of us are away from our Pi’s at the moment.


#11

I have the same problem - updated the firmware multiple times but still shows up as Firmware version 1.1
Battery Voltage 9.92 V
Also once I connect the motors I am not able to get the wheels to move, there is no movement and no red leds at the back light up


#12

Quick update on this:

  • The latest version of the firmware is V 1.1. So there’s no V 1.4. Sorry for the confusion around this.
  • We’re still trying to recreate/debug the problem with the Browswer Streaming Robot.

#13

Just another updated on this:

  • We’ve tried running all the different components of this project independently.
  • We tried running the motors and the servo at the same time.
  • We didn’t see any of the erratic behavior described above.
  • We’re moving on to the actual code of the mobile control example; it’s a little more complex than the other code.

#14

So after running the Browser Control program again, I was successfully running the GoPiGo without any problems.

Your behavior, of a motor going to full power and then the GoPiGo being unresponsive until restart sounds like the firmware on the GoPiGo is crashing. One of the things we did with the last firmware rewrite was to implement some stuff to prevent this.

One of the things we had to have done to make the new firmware work is set the low fuse to a new value.

Can you disconnect the motors and then run in the command line:

avrdude -c gpio -p m328p -U lfuse:r:-:i

When we run it, on a GoPiGo that works with the browser bot, we get

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f
avrdude: reading lfuse memory:

Reading | ################################################## | 100% 0.00s

avrdude: writing output file "<stdout>"
:010000007F80
:00000001FF

avrdude: safemode: Fuses OK

avrdude done.  Thank you.

What are you seeing after “”""?


#15

Hi Admin,
Thanks for working on this guys and helping me work out what is wrong with my GoPiGo!

OK, this is what I get when I ran the avrdude command:

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e950f
avrdude: reading lfuse memory:

Reading | ################################################## | 100% 0.00s

avrdude: writing output file “<stdout>”
:010000007F80
:00000001FF

avrdude: safemode: Fuses OK

avrdude done. Thank you.

…which looks identical to yours.

Did you see the video I posted on your FB page? That was the GoPiGo running the Browser Streaming script… going around in circles because one of the wheels/motors would not work. I will try it again and let you know my results tomorrow! Cheers.


#16

Incidentally, do you have to disconnect the servo motor as well before upgrading the firmware?


#17

Please advise if I should go thru the above to get my GoPiGo to respond as I do not get any response - all leds on RaspPi light up - the red leds on the GoPiGO do not and the motors do not respond.
I have followed all the instructions and as noted I have v1.1 of the firmware


#18

Hi,
Can you try replacing these 3 files in the browser streaming example and let up know if it helps. Just use the left joystick to control the GoPiGo.

The main change in thse three files is that the controls for the joystick have been modified to make the GoPiGo move forward, back, left and right only if a the joystick if at a position 75% away from the center. The other joystick is disabled. This should help to control the bot easily with a desktop browser.

Thanks,
Karan


#19

Hey guys,

I just replaced the files in Browser Streaming Robot with the ones in your zip - MUCH better! Both wheels are working now, however the movement seems a bit weak and turning is still a bit flaky, might be a problem with the batteries running out of juice. Might have to use some Li rechargeables instead. Will keep you all posted, but this is definitely an improvement!


#20

Hi,
Great to hear that it helped.

Now for the speed issue, the GoPiGo is not running at a 10% and is at more like 60%.

There is a setting at line 65 in robot_controller.py: gopigo.set_speed(150). Change the 150 to any speed b/w 0 and 255 and it should help with the speed problem.

Let us know how it goes.

Thanks,
Karan