Problem With Focus In Raspbian


#1

I am having problems typing in the edit windows on Raspbian. When I click in any edit window (I tried the text editor and IDLE) focus does not shift to the edit window. Any keys I press act on the background window (move between menu items or icons) not on the window in focus.

I can highlight text in the window using my mouse, but I can’t type in the window.

This problem is happening when I access the BrickPi using a directly connected keyboard, monitor and mouse as well as when I use the VNC from my laptop.

Please help.


#2

Hello @roldach

This is a weird problem that I haven’t seen mentioned in a long time. Do you use Raspbian, or Raspbian for Robots? And is it Jessie, Wheezy or Stretch ?

Cleo


#3

Hi Cleo,

It should be Raspbian for Robots. I am an educational customer working
with a BrickPi unit that I just received, so I assume the release is the
latest release you are currently shipping, although I will check when I get
back to my office later today. I installed the SD card that shipped with
the unit. I didn’t do a software update since I assumed it was the latest
release.

Thank you for looking into this!

Rich Oldach


#4

Thanks for the extra information @roldach

What type of keyboard do you use? This issue is related to the base Raspbian OS that comes with the raspberry pi, and not with the BrickPi drivers. Still, it makes it unusable.

The only time I’ve seen this problem was with people who didn’t use a standard English keyboard.

Cleo


#5

I tried it both using a standard HP keyboard (with a logictech mouse) and
standard monitor, and using my HP laptop to connect via VNC as the terminal
through the browser. I also thought it might be the keyboard and/or the
mouse, and that is why I tried the remote access via my laptop.

I am new to Raspberry Pi, but I could try loading a different version of
the OS. I have a microSD card available, so I don’t have to write over the
version shipped with the Brick PI. Would you suggest that I load a
different version to try it out? If so, do you have a version (with
instructions) that I can try?

I have access to many different keyboards and mice, so I can try a
different combination too.

Thank you!

Rich


#6

@roldach
Are you able to SSH in via PUTTY?
That will give you a strictly textual interface, no graphics at all, so no issue with focus.
Once in, you could type
sudo raspi-config
Choose localisation options
Change locale to en_US.UTF-8 (remove en_GB which is already selected)

This might help.
Cleo