Problems with GoPiGo


#1

Hi,
I’ve constructed the GoPiGo and am having problems. The SD card only installed the standard Raspbian desktop and nothing else. It appears it didn’t contain Raspbian for Robots as was written on the SD card label. There was no other option offered apart from standard open source Raspbian in the setup. It also gave an error message stating that there was a file transfer error re: a GUI file which required a password. No idea what that means as I was not even connected to the Ethernet.
I have been using a HDMI cable and a wifi keyboard and mouse with a plugged in power cable-nothing else.

The internet won’t connect to my computer (windows 7 laptop) without a “pre-shared key”. I assume that means a password though I don’t use one for my internet.
The Wifi dongle also won’t connect to my computer and it won’t connect through Ethernet either. I gather I have to find some software to run the Wifi dongle.??? Should I take the SD card out and put it in my laptop and download some wifi software? Would this even work?
I suppose I could knock up a program with Python to make it work a bit without Wifi and attached to the HDMI cable but there’s not much point.
How can I get the Raspbian for Robots software? Can Dexter send me another SD card with the software on it?
Can you please help me as I’m really disappointed with this product.


#2

Sounds like you’re not using Raspbian for Robots; did you order the SD card from Dexter Industries or another supplier? It sounds like all of the problems here are related to that . . . so before I got any further, can you be more specific about what software you’re running on the Pi?


#3

Hi,
I’ve now sorted those problems but have a new issue I’d like help with. I’ve got the pi running around with servo and sensor working using programs run in python idle in Raspian for Robots with wifi. I’ve now set up the office cannon and have tried to get it to run with your sample code as well as with your code in another lot of code but nothing is happening at all. I have connected a USB mouse to the pi and added a new battery but nothing. The other programs are still working. Below is what I’m getting when I run the module. I don’t know what it means as I’m new to all this. I have also updated in the terminal with apt-get but no luck. I am actually using a Rasp Pi 2B in my GoPiGo instead of the B+. This hasn’t caused a problem up to now. I hope you can help me.

============
>>>
Setting up
Left Mouse button- Turn left
Right mouse button- Turn right
Both left and right- Stop
Middle mouse button- Fire rocket
Move mouse to control the launcher

Traceback (most recent call last):
File “/home/pi/Desktop/GoPiGo/Software/Python/Examples/Office_Cannon/office_cannon_v1.py”, line 219, in <module>
setup_usb()
File “/home/pi/Desktop/GoPiGo/Software/Python/Examples/Office_Cannon/office_cannon_v1.py”, line 94, in setup_usb
DEVICE.set_configuration()
File “/usr/local/lib/python2.7/dist-packages/usb/core.py”, line 589, in set_configuration
self._ctx.managed_set_configuration(self, configuration)
File “/usr/local/lib/python2.7/dist-packages/usb/core.py”, line 91, in managed_set_configuration
self.managed_open()
File “/usr/local/lib/python2.7/dist-packages/usb/core.py”, line 69, in managed_open
self.handle = self.backend.open_device(self.dev)
File “/usr/local/lib/python2.7/dist-packages/usb/backend/libusb1.py”, line 716, in open_device
return _DeviceHandle(dev)
File “/usr/local/lib/python2.7/dist-packages/usb/backend/libusb1.py”, line 601, in init
_check(_lib.libusb_open(self.devid, byref(self.handle)))
File “/usr/local/lib/python2.7/dist-packages/usb/backend/libusb1.py”, line 554, in _check
raise USBError(_str_error[ret], ret, _libusb_errno[ret])
USBError: [Errno 13] Access denied (insufficient permissions)
>>>


#4

Looks like the error is because of insufficient permissions. Can you run the example as root: sudo office_cannon_v1.py. Also, can you send a link to the office cannon that you are using.

-Karan


#5

Hi,
The cannon is the exact green one that Dexter sells. It’s the Dream Cheeky one in the video posted by John on Sept2 (Sentdex’s video). I bought a GoPiGo SD card from Dexter Industries with the starter kit but it wouldn’t function and appeared to be blank when I put in the drive with 78% free space and no files on it, so I bought another one and imaged Rapsian for Robots on it. Everything else has worked since then and I have been using the new one successfully. I have run sudo office_cannon_v1.py in the terminal as you suggested but it doesn’t recognise the command. I’ve also tried it with install and apt get. I’ve typed in exactly what you said. Is this file name long enough? I don’t know what ‘run the example as root’ means so I ran it from the LX terminal as well as updating and trying to install usb and office cannon v1 again. I also tried running that command as a module in a new script and in the shell but it’s not recognised. I tried installing the pip commands that Sentdex said on the youtube video John recommended but it it’s still dead. Am I missing some crucial piece of programmimg from Dexter industries? The office_cannon_v1.py file is on the desktop and everything else appears to be in there. I note that there is a command in the v1 program which mentions B+ or B and appears to require a command there. There is no mention of Raspberry Pi2. Does that matter?
Please excuse all the questions as I am a beginner.


#6

Hi, further to my last message, I’ve just installed the office cannon on windows pc using the Dream Cheeky Software and it works perfectly. It’s great.
Is it the case that the driver isn’t installed on my Pi2 or in Raspian for Robots yet?
I suppose I could try to run the missile launcher and the GoPiGo separately at the same time but this kind of defeats the purpose and limits me in future development.


#7

Humanoid, first, sorry about the trouble using the DI image. I’m glad to hear you have it working now though.

Just to be clear and follow on Karan’s question, are you running:

sudo python office_cannon_v1.py

You wrote "I have run sudo office_cannon_v1.py in the terminal as you suggested but it doesn’t recognise the command. " So let’s try that. I think Karan might have omitted the crucial “python” in the command (it should work if there’s a shebang at the beginning of the file). Does this command, the one I pasted above, work for you?

If so, is the error the same as what you posted above, or is it a different error?


#8

Hi @Humanoid,
Sorry for the frustration that you had with the SD card and the office cannon.

I just checked the program on both the Raspberry Pi B+ and the Pi 2 and it works very well. Can you double check that you have a mouse connected to the Raspberry Pi too, because that is how you control the office cannon. Since you are using the Dexter Industries Raspbian for Robots image, go to the office cannon example by running this command from the home directory: cd Desktop/GoPiGo/Software/Python/Examples/Office_Cannon/. One you are in this directory can you run ls to check that there is office_cannon_v1.py file in this folder which is the actual program. Then run the program using: sudo python office_cannon_v1.py and the program should start. It would take a few seconds for the program to initialize and then you should get a Start on the screen. You can use the mouse connected to the Raspberry Pi to control the office cannon after that.

I have also attached a screenshot of how the commands work.

Can you try this out and let us know how it goes for you.

-Karan


#9

Karan & John
Success, yay! A capital letter or a / in the wrong place in the file path means a fail. I managed to get both the Dexter code and Sentdex’s additional code from the video (operating with just the keyboard) working as well through the Terminal so I’m pretty happy. I still don’t really understand why I can run the other GoPiGo programs just through the Python IDLE but the cannon ones have to be through the terminal. Vertical learning curve for the Noob.
Thanks for all your help. My next challenge is the open CV face recognition with the camera!

Also, I would like to learn to control the GopiGo with simple voice commands so I guess I’ll need a microphone and voice recognition software??
It would also be fun to have a speaker say “You have five seconds to comply” before firing the missile. I wonder if this is easy to do.
Thanks again.


#10

Glad to hear this was succesful. Indeed, you have to be very precise with the commands in linux.

Voice control is something we’re interested in too, but we haven’t developed any expamples yet. Stay tuned for that!