Problems with Initial Setup


#1

When I go to test for the first time I get the following
pi@raspberrypi ~/GoPiGo/Software/Python $ python basic_test_all.py
Traceback (most recent call last):
File “basic_test_all.py”, line 1, in <module>
from gopigo import *
File “/home/pi/GoPiGo/Software/Python/gopigo.py”, line 18, in <module>
import smbus
ImportError: No module named smbus


#2

Hi,
It looks like you are not using the Dexter Industries SD card. If you are not using it, they you’ll need to install a few libraries on your Raspbian Installation. Run the install script here https://github.com/DexterInd/GoPiGo/blob/master/Setup/install.sh and it should solve your problem.

Let me know if you still face any problems.

-Karan


#3

Hi,

I’ve just built my GoPiGo, added the battery pack, plugged in a HDMI to my monitor and an Ethernet cable - then powered up.

I get the green LED, and my monitor displays a page full of startup, most of which seems fine, but with one critical line:

/sbin/init: error while loading shared libraries: /lib/arm-linux-gnueabihf/libdl.so.2: invalid ELF header

then

[1.712050] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00

then about 5 lines of what looks like a stack trace:
…(unwind_backtrace…
…(show_stack…
…(panic…
…(do_exit…
…(do_group_exit…

Do you have any ideas on what I could do next?

Thanks,

Steve

PS: There is a paper slip in the GoPiGo box saying “Our firmware and libraries have been updated! Please be sure to update to the latest before starting”. I imagine this may resolve things - but I’m not sure what I can do if I cannot boot-up to a command line?


#4

Hi sharrop ,
The error that you are getting does not seem to be related to the GoPiGo. Can you try booting it without the GoPiGo and check if the error still comes.

Also, what SD card are you using. Is it a dexter Industries one or your own.

-Karan


#5

Hi,

I agree it seems too soon in the startup for the GoPiGo to have any influence. The SD card is from Dexter. I got the kit-form through KickStarter, which came with the Model B+ v1.2 Pi board and a 4Gb microSD card.

I have removed the Pi board from the GoPiGo, with just the Ethernet, HDMI and now micro-USB power (see photo) and I still get the same thing at startup.

I’m guessing maybe this has a corrupt file in the OS on the microSD card, and maybe I should go to the “Step 2: Download and use our modified Raspbian image” step?

Steve

PS: I can’t think of how to get the text to you, but I took a photo of the startup screen that I get.

PPS: I also added a photo of the full page trace

PPPS: I also put the microSD into an adaptor, then booted it in an old model A Pi board - same again. I doubted the board could be influencing this, but just thought I’d check.


#6

Hi,
Maybe it is a bad SD card, cannot say for sure. It would be great if you could download the image and try burning it to the SD card.

Let me know how it goes.

Sorry for the troubles.
-Karan


#7

Sharrop, it sounds like a corrupted SD card. If you can please follow our instructions here to download and burn a new version: http://www.dexterindustries.com/BrickPi/getting-started/pi-prep/

If the problem persists, please contact us through our website (www.dexterindustries.com/contact) and we’ll try to get a replacement to you.


#8

Hi,

I’ve downloaded and installed the latest image onto the microSD and now all is well. It fully boots up. I have updated/upgraded and reflashed; configured WiFi and keyboard and I’m good to go.

I currently have a problem with very sluggish motor movement, but I think that is the power draw on my rechargeable batteries - now refreshing.

Thanks for you help,

Steve


#9

Hi Steve,
Glad to hear that it worked for you.

Sorry for the troubles.

-Karan