Putty cannot resolve host


#1

This little project is fun so far. My 9 and 10 year old boys got it all assembled, and now ready to connect. Chromebook does not seem compatible so we are using my laptop running Windows 10. After copying new image to SD card (one that came with the kit was corrupt, fatal error at spi-dev, and never finished booting, had to work around the win32 failure from sourceforge), I have the Pi up and running. It is connected via HDMI to TV. I can remote desktop view via the VNC from dexter site. I have a wired mouse connected to the Pi itself. I just cannot connect via the ethernet, and since I do not have a wired keyboard, I am stuck. I keep getting the host not found error via Putty. Tried the supplied ethernet cord, and now running a longer cord, still no go. All lights at ports are appropriately lit (solid orange, occasional green flash) and the laptop port indicators are on solid. I have my firewall off, not sure where to go next? I have learned a lot already just from lurking the forum, but now I need help. Thank you in advance.


#2

Hi marlinvx,
On the Windows 10 machine, do you have binjour software installed, that is needed to resolve the dex.local IP that we use to connect to the Pi. If you have not installed it, can you install it from here: https://support.apple.com/kb/DL999?viewlocale=en_US&locale=en_US, reboot the computer and try again. If that does not help, can you try assigning a static IP and see if that helps, here is the link to the tutorial: https://www.youtube.com/watch?v=P4yg8RYtTJs.

Do let us know if this works for you.

-Karan


#3

Thanks Karan. I installed bonjour, but never rebooted, as it never prompted. Will do in the morning and uodate post.
I did run the diagnostics test on the bot, wheels turned looked good. Super excited to put the boys to work on programming. I have some experience in plc programming and macro programming using if,and,or etc…should be fun for all.


#4

Okay, I got the static assigned, can ping via command window, looks good, dex.local pings as well. Putty still will not connect. Do I need to do anything other than install bonjour, it looks to just be a printer sharing program, and only shows my wireless printer in the listing?


#5

Hey Marlinvx, with the latest, you can login and use terminal on your browser at dex.local. If you go to http://dex.local, you can login through the browser.

If you still need to use putty, what settings are you using on putty? Some folks still want to use it; so you should be logging in to dex.local, as user pi, with the password robots1234, on port 22.


#6

When I use dex.local in my browser, it brings up the desktop, but I cannot manipulate anything. In Putty, I just used dex.local instead of the directed “raspberrypi.local” found in the setup instructions, I am in now:) Thanks for that, might want to update the setup instructions on the website to reflect the change. Thanks again! Time for fun.


#7

Huh, that’s intersting. What date is on the image you used or SD card you downloaded?

Also, where did you see “raspberrypi.local”? Can you provide the link? We tried to scrub these out when we made the change on our image. This will help us help other folks.

Really sorry abotu the confusion, but I’m really glad to hear you’re up and running!


#8

The SD card it came with dated November of 2015, I scrubbed that and downloaded the newest straight from the dexter site. Here is a link to where I found the setup instructions. http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit-2/4-connect-to-the-gopigo/ Still having problems via the VCN access. Via the browser, as I said, I see the desktop, but cannot manipulate anything except the task manager. If I use the VCN program, it tells me “denied by the host computer”. I closed the putty and VCN browser access first. Will try again.


#9

Sorry, VCN, not VNC, I was thinking it stood for virtual network controller, guess not…:slight_smile:


#10

Just checked the printed manual, it does state dex.local vice rasprberrypi.local. I also noticed it said if using a touch screen windows, to run firefox vice chrome. I am trying that now.


#11

That worked! Setting up wifi now. Firefox did the trick. Thank you again, if you ahve any more questions, let me know.


#12

Good news and bad news. I have it up and running, can access via firefox, got the wifi setup. I can see the Pi on my network map, can ping via wifi using command window.
I cannot connect to the Pi via wifi. I keep getting the 1006 error at the VCN window. If I reconnect ethernet, I can connect, but it keeps booting me off after a few minutes, same error, 1006. There does not seem to be a rhyme or reason to the LAN disconnect, sometimes its 10 seconds, sometimes its two minutes. I thought maybe it was a time out connection for inactivity, so I tried manipulating various folders, still get booted randomly. Any thoughts?


#13

The only way we’ve seen folks correct the 1006 error is by reburning the image. I don’t know why that happens to VNC. Are you sure it’s rebooting or is the wifi connection just flakey?


#14

WiFi is solid, just says rejected by host. I watched reboot on monitor. I will try to burn image again, I have it on my desktop.