Raspberry Pi 3 and GoPiGo Image - No Support for Built in Bluetooth?


I can configure the built-in Wifi module on the 03.28.2016 Raspbian for Robots Image. However, I need to be able to use the built-in Bluetooth module on the Raspberry Pi 3 with Raspbian for Robots. This does not work. When running “hcitool scan” - “Device is not available: No such device” is returned. This works out of the box on the new Jessie image…

Unless there is some error on my part, can you guys please hack the Wheezy image you are using so that it also supports the built in Bluetooth module on RPi 3?

Or, port the Raspbian for Robots functionality and applications to Jessie. Unless the port is done, you can’t be sure that the image will fully take advantage of the RPi 3 hardware advances. Just my opinion without doing thorough research about the truth of that statement…

If the hack can be done, please let me know an approximate time to expect it. I have a demo next week, and if this will not be ready it would be nice to know sooner than later.



Hey Howard,

Couple of thoughts here. First, the Bluetooth and Wifi compatibility with serial lines is a known issue. Folks smarter than us figured out how to make it work with the Pi 3, but it leaves Bluetooth un-usable os of today. The Pi Foundation is aware of the issue and working on it. This article explains it in much better detail; http://www.briandorey.com/post/Raspberry-Pi-3-UART-Overlay-Workaround

The contradiction is in serial; so if you’re not using Serial (like you’re using the GoPiGo or GrovePi) you can take your own version of Jessie and run one of our install scripts to set it up and use it.

We are working on an update to Raspbian for Robots that uses Jessie; there are some major differences in the software we’re trying to work through right now.



Thanks John.

I like the idea of installing the applications on Jessie, but it is not nearly as straightforward as using the image you guys have already set up and fine-tuned. If I could solve the following things when installing to Jessie, I would be happy.

  1. The webserver that you can browse to on the Raspbian for Robots image that allows users to select noVNC or the command line is cool. It does not seem to install when using the install instructions on the website, or if it does it won’t run. Sure I can ssh into the Pi and install xrdp or a VNC server on my own, but I like using the one via the web-browser for demos and teaching. Can you, on your website or this thread, show me how to set that up?

  2. When using the Scratch control programs you have to install scratchpy and manually run the GoPiGoScratch.py program. I get that. Can you tell me how you get GoPiGoScratch.py to run automatically on the Raspbian for Robots Image? I assume that it is running in the background on that image or runs automatically when you start Scratch, and I would like to duplicate however that is done on my Jessie image that students will use. With all this being said, I highly recommend including these types of install nuances in the main install script or clearly on the website. Please accept my apology if this is on the website, and please send me the link.

  3. When trying to run robot_web_server.py I encountered errors. To start with, I had to install python-tornado and sockjs-tornado manually. Then, I had to move the GoPiGo folder to the desktop because the path did not match what was in the script (that’s not mentioned in the ‘cook your own image’ instructions – Option 3 on the website). All these things are minor, but should still be addressed on the website or in the install script. However, even after making these changes the stream website showed up but the camera wouldn’t stream. I have attached the error to this message.

To conclude, the website could provide more support for people in the Option 3 category that choose to use their own image. As for me, if I can get some help with these three things that will help me have a successfully demonstration next week. Again, this all stems from me needing to use the built-in Bluetooth on Pi 3 and not being able to on the Raspbian for Robots Image. Otherwise, I would just use that one.



Hey Howard,
We are working on getting our software working with the Jessie. There are a couple things which we are still working on like noVNC which is still facing some problems on Jessie. VNC does work but noVNC does’nt.

All the functionality in our image is based on the script here: https://github.com/DexterInd/Raspbian_For_Robots. If you want to try this, just clone the directory on /home/pi/desktop and then move the update_backup.sh to /home/pi and run it which will make the icons on the desktop and then run the DI software update from the desktop to install everything. However this is still in development for Jessie and you should only try this if you are fine with bugs which would be there. If you go this way, it would be great if you could send us some updates about the problems you face and any solutions too.

The scratch GUI might be a bit complex to explain and the main script does that too. It is pretty custom built for our image so we did not publish a lot of documentation around it because it is more or less bound to cause problems with other images unless they get the environment created by the Raspbian for robots image.

Right now we are working on getting all these issues sorted and I think you would run into the issues too when you are using your own image with all the software that we have built for Jessie. I think the Jessie image would be ready in a few weeks but no ETA yet, however this is our highest priority right now. If it takes more time that would most probably mean that they are more difficult bugs to squash.

The robot web server error seems to be coming becasue raspberry_pi_camera_streamer is not installed on the Pi. Did you run this script on the Pi https://github.com/DexterInd/GoPiGo/blob/master/Software/Python/Examples/Browser_Streaming_Robot/browser_stream_setup.sh and check that it finished properly.

We’ll look into making option 3 a bit more descriptive for people, but that option is mostly for people who don;t need things like GUI and are happy using the terminal and comfortable with tinkering scripts and linux in general. We usually spend a lot of time in making sure that our image works for almost everyone with every kind of usecase. It also makes it a lot easier for us to help out people who are having any troubles.

Bluetooth is also on our list of things to test with the jessie image but I am 100% sure that we would be releasing it before your demo. So might have to use your own image if you want to use onboard Bluetooth. We have tried using Bluetooth on the B+ and Pi2 with one of the projects and an external Bluetooth adapter. You can go that way if all you want to do is use bluetooth.


Hi Karan,

Thanks for the response. I just gave in and purchased a compatible Bluetooth and Wifi Dongle. I will use my RPi B+ or 2 for the demo. More cost, but everything I want to do will work without the headache.


Hey Howard,
We have just updated the Raspbian for Robots image to Jessie. You can find out more details here: http://www.dexterindustries.com/topic/jessie-raspbian-for-robots/.
Bluetooh now works with the Raspbian for Robots image.


Hello, I upgraded my raspbian to jessie,
but I still can’t use bluetooth.
Is there any tutorials on how to set up bluetooth?


Hi @shitian.ni,
We tried to test the bluetooth and were were getting the same problem. We are looking into this and will get back to you in a bit. Are you using the latest version of Raspbian for Robots.

Hi @karan
Thanks for following up.
I think I am using the latest version of OS.

Thanks for letting us know. We’ll test it and get back to you

Is there an update for this issue? I’m having the exact same problem. Thanks.

Hi @willd,

We are working on this issue, we have a solution but it isn’t very stable to work on all images. We are still debugging and hoping to have a support for this soon.In the mean time you can try the solutions given here and let us know if that helps.