Raspberry Pi 3 not booting after new GrovePi install


#1

Hi All,

I have recently downloaded 2017-06-21-raspbian-jessie, and installed the new version,
and set it up as I would normally do. With out any Problems.
I then tried to install the GrovePi package.

During the installation I noticed a number of errors, when completed I rebooted.
The RPi would not complete the boot process, so was not usable.

I performed same re-install on a clean 8gb card 3 times and still no working RPI.

Please can you advise, txt file of install log included.

Many thanks MichaelInstall_GrovePi_error.txt (24.4 KB)


#3

Hi @whimickrh,

Okay, that is new to us.
We’ll try to test the install script and see if we get the same thing as you.

My guess is that there’s something with the kernel.

Thank you!


#4

I am having the same issue, using the 6-21 distro of Raspbian. The Pi hangs on boot, after showing the 4 raspberries. If I unplug the GrovePi+ it boots fine. If I plug the GrovePi+ in after boot (yes I know that’s a bad idea), it works fine (detected via i2cdetect and the basic “blink” Python script works).

I must confess that I ran the install script with the GrovePi+ plugged in – and the Pi booted fine with the GP+ plugged in prior to running the script.

thanks,

Dave B.


#5

So @RobertLucian and I are digging into this a bit. What I saw was the following:

  1. Download the new Raspbian Image 2017-06-21 2017-06-21-raspbian-jessie.zip
  2. Attach the GrovePi and try to boot. I saw the boot stop at 4 Raspberries.
  3. Reburned the new Raspbian Image 2017-06-21-raspbian-jessie.zip
  4. Booted the Pi again, no GrovePi attached, and ran the install script. Once I ran the install script, the Pi booted fine after that.

Also, I installed GrovePi+ with the following command: sudo curl https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/fetch_grovepi.sh | bash


#6

As an update working on this a bit, @RobertLucian and I both tried this operation over again:

  1. Download the new Raspbian Image 2017-06-21 2017-06-21-raspbian-jessie.zip
  2. Attach the GrovePi and try to boot.
  3. With the monitor attached, I could see that Raspbian booted normally with no problems.
  4. Ran the install script sudo curl https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/fetch_grovepi.sh | bash (which does the same thing as the install script in our setup, it’s just a single command to install though).
  5. No problems booting.

#7

Hi I glad it may have been fixed, I will try with the new image over the weekend.

Michael


#8

Hi all,
I have just downloaded 2017-07-05-raspbian-jessie.
Then used https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/fetch_grovepi.sh | bash

RPI3 booted ok without GrovePI+ plugged in, then powered down fitted GrovePi got a few green flashes on RPI, then stalled, Screen just shows Raspberries.

One thing I have found is that there may be greater power requirements, and found that older RPI power supplies could not power the RPI and GrovePi together, after using later versions of raspbian-jessie this has affected all of my RPI’s so I replaced my power supplies with the new RPI power supplies that provided a greater amp-age above 2.5amps. Which appear to have solved the power issues?

If your red led on your RPI flashes then you may need to replace its power supply.
Official Raspberry Pi International PSU with UK, Euro, US and Aus. Plugs & Inline Switch Lead – White

Sadly it did not solve the GrovePi software issue.
Michael


#9

Hi @whimickrh,


Your not-so-good power supply might have corrupted the micro SD Card.
So, when you’re trying to boot the Raspberry Pi with the good power supply, the system might not boot because the micro SD Card is already corrupted.

Here’s what I would do:

  1. Burn a new image of Raspbian For Robots on the micro SD Card.

  2. Boot your Raspberry Pi with the good power supply.

  3. Use the curl https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/fetch_grovepi.sh | bash command.

  4. Update the GrovePi's firmware and check an example program.
    Use the instructions found on the following page: https://github.com/DexterInd/GrovePi/tree/master/Firmware


I think this might solve your issue, Michael.
Please let me know if this is good for you.


Thank you!


#10

Robert
Sadly if I use Raspbian_For_Robots I am unable to install some extra software that I use, for example nginx.

Has any progress been made as to why the latest Raspberry Pi’s 2017-07-05-raspbian-jessie will not work with a GrovePi plugged in.

And is there a possible problem that future versions of Raspbian_For_Robots will have the same proplem?


#11

There should be no issue (in theory) that would stop you using nginx on Raspbian for Robots. Apache comes pre-installed but you could turn it off so nginx would be the one that will serve port 80 instead. What issue were you facing in installing it?
Cleo